Can the OpenCL SDK and CUDA SDK coexist on the same machine?


I would like to install the OpenCL 1.0 Conformant Release on a machine that is already running CUDA SDK 2.2. This machine is shared among different people in my lab so I wouldn’t want to uninstall the CUDA SDK. From what I read on the OpenCL Release Notes document, it seems that these two SDK’s can’t coexist on the same machine. I would like to confirm this with other people on this forum.

Thank you,


the opencl nvidia releases are installed in a separate directory ( e.g. ~/NVIDIA_GPU_Computing_SDK ). nothing else is touched (at least using linux).

the only requirement is to use the driver version 185.18.08

I am in the same situation, where I would like to ‘dual install’ both the CUDA SDK and the OpenCL SDK. Could an NVIDIA employee or someone that has tried it comment before I possibly cause myself issues when trying to accomplish this? Thanks in advance for help.

they are entirely separate and should cause no problems together.

I installed CUDA and OpenCL SDKs on the same machine and everything appears to still work…

Unfortunately it’s not always so easy. OpenCL does need the 185 drivers… NOT any other ones, including later ones.

In Linux at least, the CUDA 2.3 beta drivers are 190.x and those work great for CUDA but OpenCL programs will no longer run, complaining about the 185/190 conflict. (The error message claims in fact that there’s an API mismatch with the kernel module 190 and driver at 185… but actually the driver is really 190 as well.)

All solved by just going back to the 185 driver, but then of course you don’t get the 2.3 CUDA beta.

I assume that later drivers (non beta) will work with both.

On Windows Vista 32 the installer for the CUDA 2.3 SDK only proceeds after uninstalling the openCL conformant SDK and vice-versa for me. That is I get a messagebox with the text when I install either of the SDKs and the other is already installed.

I’ve been wondering if this is a problem with my system specifically or if this always happens in Windows.

EDIT: clarified a bit

Yes they can. I’ve successfully managed it. The only requirement is to use similar driver version (since you can only have one installed at a time…). That means that by now you have to install Cuda 2.2 since drivers 190.38 used in Cuda 2.3 are not currently supported in OpenCL.

By the way I’m using a Windows Vista 64 bit, Cuda 2.2 and OpenCL 1.0 Beta 1.2

I’m going to try next having both in the same project… i believe that’s not possible… :P (if anyone already tried please post here the results)

Tiago Neves

So how exactly did you you successfully manage it? My sequence below generates the same you need to install the previous version type error.

Step by step - I installed the 64 bit version of 190.89 (which is what the open cl page steers you to) (nvdrivers_2.3_winvista_64_190.89-beta_notebook.exe)

Then I installed the OpenCL SDK - gpucomputingsdk_2.3b_win_64,exe

Then I install the CUDA toolkit - cudatoolkit_2.3_win_64.exe

then vomit…

I didn’t even get to install the SDK…