cannot debug at EmuDebug mode

I ran into a very strange thing.

I started with cppIntegration example. At EmuDebug mode I am able to debug into any kernel to see the values. Then I developed my own kernels, added many C/C++ code and then when I want to debug at EmuDebug again, I found out I am not able to debug into any kernel any more. I did not change any setting on the main .cu file, which now includes several other .cu files.

Compilation and run are fine. But I am not getting correct result. So I hope to debug into kernels to see what happened. But I cannot debug. Even if I tried to use printf() code in a kernel under EmuDebug mode, the printf() code simple did not show any output in the console window.

This is really strange. Did anyone meet similar problem before? I’ve checked the project setting for the whole day also searched this forum, but did not locate an answer. Any suggestion will be highly appreciated. Thanks,

Environment: Windows XP , 32 bit, Visual Studio, CUDA 2.3, run on FX570M, Levono T61p laptop, 3G memory.