Cannot debug CUDA (Pascall)

Hi there,

I just got a new GTX1050 laptop (XPS 15) and I’m having trouble getting CUDA debugging to work.
I installed VS2015 (Community), Nsight Visual Studio edition 5.2, CUDA Toolkit 8.0 and the latest GeForce driver (378.49).

I tried to execute the default template and it runs just fine.
But when I try to debug the application, I get a warning/error message: “A CUDA context was created on a GPU that is not currently debuggable”.
According to the Nsight requirements, my laptop (and Pascall in general) should be supported for CUDA debugging:

Does anyone know how to fix this?


Hi Mathijs,

Of course nsight supports 1050, could you try the latest nsight at

Best Regards

Hi Harry,

Thank you for replying.

I see that there is a newer version available for both CUDA (8.0.61) and Nsight (
Downloading now, will update the post when I tried both.

Installed the new CUDA/Nsight releases and it works!
Thanks Harry for the links!
Apparently I either used the wrong links to download it originally or it just got updated in the last 2 days.