Nsight 5.2 - can't debug with GTX 1050Ti in vs2015(Win7 SP1)

My env:
OS: win7 sp1
vs: 2015
cuda sdk: 8.0
nsight: 5.2
device: gtx 1050ti


  1. can not start cuda debug in vs ngisht->start cuda debug. error message:
    Adapter: GeForce GTX 1050 Ti
    A CUDA context was created on a GPU that is not currently debuggable. Breakpoints will be disabled.

  2. nsight->start proformence analyise… this can run trace cuda(trace settings), bug system trace setting can’t set with error:
    failed to start capture, trace with system enabled requires the event tracing for windows kernel logger, which can only be use by one tool at a time…

i would be greatful for your help.

OS: win7 64bit sp1
cpu: i7-6700K
ram: 24 gb

Hi Lipson,

A1: Could you tell me the detail verion of driver and nsight you use?
A2: trace with system enabled requires administrator privilege, run the nsight monitor as administrator can fix it.

For your picture, you are trying to debug a lib? windows cannot launch a lib, please try to launch the exe which uses this lib.

Best Regardsh

Thanks,detail fellow:

Nsight: build
Device: GIGABYTE GTX1050Ti
Device driver: (ps. I can not find the Nvidia driver version, install by last cuda sdk 8.0.44 windows)

I have upload the right pic again…

I found my driver version in cuda sdk 8.0 installed is :
3D vision controller driver: 369.04
Display driver: 375.70

Could you please try the latest nsight and driver 376.01 at https://developer.nvidia.com/gameworksdownload#?dn=nsight-visual-studio-edition-5-2-0

Or just try the latest cuda 8.0.61, it includes everything you need, I’m afraid doesn’t work well with pascal on 375.70

Yeah.your suggest work!!! installed the newest version.