Cannot use Nsight Debugger Visual Studio Edition

I will begin by giving my specs and then will outline the myriad of ways that I have tried to resolve this problem. When I list multiple versions, it means I’ve tried almost all possible configurations (i.e. driver xyz with CUDA x.y and Nsight y.z)

OS: Windows 10 (64 bit)
GPU: Quadro K600
Drivers: 388, 419, & 430
Visual Studio 2015 Professional
CUDA Toolkit: 9.1, 10.0, & 10.1
Nsight™ Visual Studio Edition: 5.4, 5.5, & 2019.2

I know the the GPU will correctly execute my code when I just run my application normally (not with the Nsight debugger) However every time that I run Start CUDA Debugging, the application will “enter break mode” with the standard error output:

CUDA context created : 21a47a196f0
CUDA module loaded: 21a7a5157f0
CUDA grid launch failed: CUcontext: 2311894177520 CUmodule: 2312744556528 Function:

Things I have tried:

  • Increasing WDDM TRD Delay.
  • Uninstalling all drivers, toolkit and Nsight and then reinstalling in every possible permutation of order in nearly every possible configuration.
  • Running the pre-installed sample MatrixMul with Nsight debugger.

All of these result in the same error sequence.

What interests/frustrates me most about all of this is that initially the debugger was working in my own project fine and I used it to debug some of my logic. Then out of the blue, it would no longer work, and I really don’t think I did anything like update driver, toolkit version, or Nsight. I tried a few things and eventually ended up having to uninstall and reinstall everything for the first time, and it worked. This configuration was driver 388 (I believe, as this is the one CUDA 9.1 installs automatically), CUDA toolkit 9.1, and Nsight 5.4.
Next I attempted to update to Nsight 5.5. This made the debugger not work again. I figured it was no problem and that I would do what I had just done and uninstall everything and try to reinstall driver 388, CUDA 9.1, and Nsight 5.4. Unfortunately this time it did not solve the problem.

I have since tried uninstalling everything and then reinstalling all the different combinations of drivers, CUDA toolkits, and Nsight versions with the versions mentioned above (Yes, this took forever) and I have still not been able to get the debugger to run correctly again.

I guess I should also mention that sometimes while installing or uninstalling a component (using the NVIDIA installer/uninstaller) the progress would freeze (and I don’t mean for just a few minutes or hours. I would at first let it run for about a day until I was sure something was wrong) to the point where I would have to restart the computer. Usually when this happened, the restart would take a long time to actually shut down the computer and then before restarting a blue error screen with the error DRIVER_POWER_STATE_FAILURE would appear.

I really have run out of options and need some guidance.
Any help would be greatly appreciated.