Start CUDA Debugging greyed out

I recently installed Nsight Visual Studio Edition 3.0 RC1 in hopes of debugging CUDA 5.0 (which I have already installed and which works).

After install, I was able to start the Nisght monitor without issue. But upon starting Visual Studio 2010, I was given a criptic error that offered the option of showing the error or ignoring it. If I opted to show the error, nothing happened. No new dialog, no error, just nothing shows up. I unfortunately neglected to take down what the popup said on it. I clicked ignore since I didn’t have much of an option to do anything else. When I clicked the drop down Nsight menu option, all options are greyed out.

I closed and reopened Visual Studio. This time I don’t get any errors or popups, but everything is still greyed out. I uninstalled Nsight, rebooted my computer, and reinstalled. I still didn’t get any errors, but at the same time, everything is still greyed out.

Does anyone have any idea why the options are greyed out and/or potential steps I can take to figure out how to make them useable?

Type: Laptop (HP EliteBook 8540w)
OS: Windows 7 x64 Professional
CPU: Core i7 Q820
RAM: 16GB
GFX: Nvidia Quadro FX 880m
GFX Driver: 306.96 (Note: I’m at this driver level because every Nvidia driver I have tried seems to cause my computer to BSOD at even the slightest… disturbance. The MS “certified” drivers seem to be more stable, but aren’t much better. The most stable drivers I can find are the ones from HP themselves, which has 306.96 as the latest version. I would rather not have to try to install a newer driver as “useable computer” >>> “running Nsight”)
CUDA: 5.0 (Notebook x64)

I’m very new to CUDA development, but if you have any questions or comments, let me know.

Please try removing all Visual Studio plugins (including Nsight), then start a Visual Studio 2010 Command Prompt and type: devenv /resetsettings

Then try re-installing Nsight for Visual Studio.

Sorry for the long delay.

I uninstalled Nsight and plugins, reset the settings, and reinstalled. The options are no longer greyed out, but now when I try to Start CUDA Debugging, it connects to the Nsight Monitor and disconnects almost instantly. I’m connecting to the same machine I’m debugging on.

Does your application continue to run after the Nsight Monitor disconnects?

I am not quick enough to start debugging my application before the Nsight Monitor disconnects.

So your application never starts? It just connects and then immediately disconnects?

Would you mind providing me with a detailed log? Please follow these steps:

  • Close Visual Studio and the Nsight Monitor
  • Go to %AppData%\NVIDIA Corporation\Nsight\Vsip\1.0\Logs and %AppData%\NVIDIA Corporation\Nsight\Monitor\1.0\Logs and delete any existing files, do this on both machines (host and target) if applicable
  • Edit Nvda.Diagnostics.nlog as follows
    • For the host/client machine, it will be:
      • For 32-bit OS: Program Files\NVIDIA Corporation\Nsight Visual Studio Edition <Nsight_version>\Common\Configurations
      • For 64-bit OS: Program Files (x86)\NVIDIA Corporation\Nsight Visual Studio Edition <Nsight_version>\Common\Configurations
    • For the target/server machine, it will be:
      • For 32-bit OS: Program Files\NVIDIA Corporation\Nsight Visual Studio Edition <Nsight_version>\Monitor\Common\Configurations
      • For 64-bit OS: Program Files (x86)\NVIDIA Corporation\Nsight Visual Studio Edition <Nsight_version>\Monitor\Common\Configurations
  • Go to the last logger at the bottom of the file:
  • Change the minlevel attribute value from “Error” to “Trace”
  • Save file
  • Reproduce the problem, and send the generated logs: %AppData%\NVIDIA Corporation\Nsight\Vsip\1.0\Logs and %AppData%\NVIDIA Corporation\Nsight\Monitor\1.0\Logs

Again, I apologize for the time delay. Do these forums have any way to auto-notify when a new response is posted?

Regardless, I have a bit of an oddity. It works now. The only major change to my system has been that Windows Update wanted me to update from IE9 to IE10. While that might not be related, my system does seem to be a lot more stable since that update… which makes me worried about what was in IE9.

If the issue comes up again, would you like me to provide these logs?