How do I track down the missing environmental factor to have Nsight monitor connect to a program?

Hi guys, The problem we are having is, on one computer our program won’t display the option to connect the process to the visual studio Nsight debugger. The program we are working on is a plugin for another program.

So I start Nsight monitor and in options for it I set under CUDA , debugger , Use this Monitor for CUDA attach to TRUE.
I start my visual studios 2008 project and goto debug > Attach To Process
This brings up the Attach to Process window. I select the Nsight GPU Debugger. Under Qualifier I find my computers name and select it.
Nsight monitor says 1 connection
Attach to is Automatic.
Refresh after starting the external program that runs the CUDA plugin of ours.
Under Available Processes, I can see the program that I want to attach to but the attach option is disabled(greyed out). All the programs are greyed out. Under type none say CUDA

Under section 5.a of the Attach Debugging to a Running CUDA Process page it says.
If a process is grayed out and CUDA is not listed in the Type column, then it cannot be debugged with the CUDA Debugger. Usually this occurs because the NSIGHT_CUDA_DEBUGGER environment variable is not set in that process.
I set NSIGHT_CUDA_DEBUGGER = 1 in the system variables by hand.
This had no effect.
http://http.developer.nvidia.com/NsightVisualStudio/3.0/Documentation/UserGuide/HTML/Content/Attach_CUDA_to_Process.htm

I have uninstalled and reinstalled Nsight. I had version 3.0.0.13123 now I have 3.0.0.13150
I had the 311.50 drivers and have updated them to 320.49

System information:
Computer : Gateway DX4850
CPU:Intel® Core™ i5-2300 CPU @ 2.80GHz
Ram: 6.00 GB
Card: Quadro k5000
Driver version: 320.49
OS: Windows 7 service pack one

Nsight version: 3.0.0.13150

CUDA Version: Release 5.0, v0.2.1221

Is there something I could check in the registry.
ANY more ideas would be greatly appreciated.

I can provide more data about computer once I know what is needed. The program is proprietary so I doubt I’ll get permission to post certain portions of the code, but I think the config files if needed would be fine. I might not have mentioned something we tried so just ask.

Thanks in advance.

EDIT:
I have followed these
https://devtalk.nvidia.com/default/topic/529718/start-cuda-debugging-greyed-out/
Steps and have some log files. To whom could I send them.

Hi,

Double checking, after you have set the environment variable and also set the Nsight monitor setting to ‘True’, did you restart Visual Studio and the Nsight Monitor?

Are you doing local (single machine) or remote (2 machines) debugging?

I was working on a different project for awhile but I am back on the previous project.

I am doing local Under
Attach to Process -> Qualifier
I am using mymachine rather then localhost

A few updates for my system
https://developer.nvidia.com/rdp/nsight-visual-studio-edition-early-access
These are the current versions I have downloaded.

How do I find out if I have 319?

I have updated my nvidia drivers since my original post to the 326.19.
Cuda to 5.5.

I also had to update the paths from
C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v5.5
to
C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v5.5
For the relevant paths.

These are my Nsight settings.

NVIDIA  Nsight
Visual Studio Edition 3.1.0.13204

Nsight settings

    [*]General
      [*]connection
        [*]monitor port 8000

      launch

        [*]Synchronization Directory blank

      Microsoft Display Driver

        [*]WDDM Delay 2 [*]WDDM TDR Enabled True

      NVIDIA Display Driver

        [*]Driver instrumentation enabled False

      Security

        [*]Enable pre machine permissions False [*]Enable secure connection False [*]Trusted machines MYMACHINE;mymachine

    Analysis

      [*]Analysis
        [*]Report Directory c:\temp

    CUDA

      [*]Debugger
        [*]Desktop GPU’s must use software preemption True [*]Headless GPU’s must use software preemption True [*]TCC GPUs must use software preemption False [*]Use this Monitor for CUDA attach True

    Updates

      [*]Check for updates
        [*]At application startup True
[*]Notifications
    [*]Turn on all update notifications True [*]Turn on notifications for current new version found True

Configuration
The Nsight Monitor on MYMACHINE is properly configured for Nsight GPU debugging and analysis sessions.

Connections
Debugger (mymachine)

1 connection when on

I’m trying to connect to 3D Studio Max. Could there be some setting that is preventing me from connecting to 3dsmax?

Would you mind sending the logs to devtools-support at nvidia dot com? Thanks.

Gladly :)