NSight does not show attach processes

VS 2013. Previous NSight v4.7 worked fine.

When I do Debug-attach to process and choose NSight with localhost, no processes are shown in the list. NSight Monitor is running.

I just “upgraded” to 5.0. Please fix this. :(


Do you mean attach to a Cuda application? If yes, you need to set an env NSIGHT_CUDA_DEBUGGER=1 then launch your application. If in Windows 10, you also need an admin command line to set the env. Thanks.


Of course, just like v4.7 which as I said, works. 5.0 does not. Not using Win10.

May I know your operation system, driver version and GPU? Could you try to reinstall driver and then install Nsight again? Just want to make sure driver related dll files are not broken. Thanks.


Windows 7 Pro SP1
Titan Black

I won’t have time to re-install for a while.

I will install the new driver soon.

I’ll try to “upgrade” NSight again when there is a new version posted.

I can attach to a Cuda application correctly in Nsight 5.0 with your config (Win7+358.05+Titan Blanck). Looking forward your experience of new driver.

I reverted back to v4.7 w/o changing anything else and it works.

It’s a strange thing. I want to make sure one thing. In Nsight 5.0 monitor options, Use this Monitor for CUDA attach is set to true, right? Thanks.


I didn’t check that or change it, so it was whatever the default setting is when installing over v4.7 which works.