Attach to process, Nsight Eclipse 7.5 on Linux

Hello everybody,

lately I’ve been trying to debug a shared object within the context of a running application (which happens to be Matlab, but that shouldn’t matter).

While this is no problem on Windows using Nsight Visual Studio, I just can’t seem to figure out how to do the same on Linux.

When I select “Run”->“Attach…”, the following output appears in the Console tab:

attach_launch [C/C++ Attach to Application] gdb
Coalescing of the CUDA commands output is off.

I’ve also tried creating a Debug configuration of type “C/C++ Attach to Application”, but the effect seems to be the same.

What’s strange is that I never seem to get asked about the process ID I’ like to attach to.

Even though finally I’ve successfully used cuda-gdb on the command line to solve my debugging problem, I’d really prefer to do it in the GUI. Am I just missing something, or has anyone had he same issue?

Any help would be greatly appreciated.


Ok, bad topic I guess… zero views in 2 weeks.

Seriously, is there nobody who ever wanted/tried to use this feature?

In the meantime, I’ve tested CUDA 8.0 as well, doesn’t seem to make any difference.

Hi, audax

Thanks for reporting this.
The feature not supported on cuda8.0 and before.
And it supposed to be supported in future release.

Sorry for the incovinience.