NSight 5.1 shows no processes when attaching a CUDA process for Debugging

Hello,

I tried to use the “Attach to Process” option in Visual Studio to attach Matlab that runs a CUDA code in a dll, but no process list for the localhost is shown for the NSight GPU Debugger. This worked fine with the older (<5) versions. In the “The Attach to: Automatic” dialog the “Automatic” is grayed out.
All monitor and VS setting are done as recommended in the documentation of NSight 5.1 and the connection of the monitor to the localhost is established. NSIGHT_CUDA_DEBUGGER is set.
The configuration is:
Cuda 7.5
Nsight 5.1.0.16062
NVidia Graphic driver 361.91
Visual Studio 12.0.21005.1 REL
Windows Server 2012

Does anyone have an idea what might cause the problem?

Hi janv,

It looks like a monitor configure issue, please make sure the following things

  1. set NSIGHT_CUDA_DEBUGGER=1 before run the app (looks you did it)
  2. make sure that the “Nsight Monitor options -> CUDA -> Use this Monitor for CUDA attach” is set to true
  3. On win10, maybe win7 also, you need to launch the Nsight Monitor with administrator privileges as windows require it to attach the process.