Can't attach to launched and captured process on Ubuntu

Tried multiple versions of Nsight even the latest one. I can capture (with F11, or ctrl+Z on older Nsight). So I can see the HUD/overlay and I can use hotkeys to move between frames. But I can’t attach Nsight UI to the selected process, it’s just grayed out (disabled) in list of processes.

I had some success in a past on older ubuntu+nsight, but I don’t remember which version was ok. So I don’t know since when the nsight got broken.

Ubuntu 20.10
NVidia driver 460.32.03
GeForce GTX 1050 (on laptop)

Hello,
Thank you for using Nsight Graphics. I spoke to the engineering manager on your issue and please note that when the process name is grayed out in the process list, this usually means the activity name environment is not correctly set for that process. If launch succeeded, this should not happen. Here a couple of other points to note.

  1. I see you are using Fedora 33 which we never tested with, however, we do support Fedora30
    Moreover, we have several improvements on the injection, you should try Nsight Graphics 2021.1 as the first step. Just launch from Nsight GUI, not manually with LD_PRELOAD.

  2. If 2021.1 does not work for you, then you could try to manually launch with LD_PRELOAD, but must with NV_TPS_LAUNCH_TOKEN=”Frame Debugger” (the Frame Debugger could be other activity name based on what he want to use).

I already given up on Fedora. So I tried the most compatible system.

It doesn’t work. Also the error messages could be more verbose, not something like “Launch failure: Process creation failure”.

Thanks. It helped. Finally I was able to “unlock” the process and attach to it. Those variable should be somewhere in the documentation as fallback option.