Latest Nsight Graphics (2018.5.1.18263) doesn't launch nor shows processes (Linux) (Solved)

Hi. I have installed Nsight Graphics on Ubuntu 16.04 64bit. My GPU is Quadro P4000. I am trying to debug OpenGL (core 4.5) based graphics app. If I launch the process from within the Nsight,it never starts up,the console shpws “Trying to connect to process on host:localhost…” and nothing happens.
Then I also tried to attach to process.But in this case there are no processed shown up in the Nsight UI even though the target app is running. Btw,I launch the Nsight by running nv-nsight-gfx file.I haven’t found any other way.So what can be the problem. I run those processes as sudo so the secureity shouldn’t be the issue here.


  • What is your driver version? How did you install the graphics driver?
  • Can you try launching glxgears? It comes from mesa-utils packages if I remember correctly.


I have exactly the same problem. I have an Ubuntu 16.04 with a Quadro M1000M and the driver version is 396.54 from ppa:graphics-drivers/ppa. glxgears works without problem. After 3 attempts to start a process it claims that the process may already have exited but it never even has started.

Edit: Same problem appears with 2018.4 version of Nsight Graphics. But it works on a different machine with a GTX 1080 and Ubuntu 18.04

Edit2: I tried also LD_PRELOAD=/usr/local/NVIDIA-Nsight-Graphics-Linux/target/linux-desktop-nomad-glx-x64/ with my executable to later attach with the graphics debugger. This causes a segfault with following callstack:

#0 __memmove_avx_unaligned () at …/sysdeps/x86_64/multiarch/memcpy-avx-unaligned.S:118
#1 0x00007ffff28799d9 in ?? () from /usr/lib/nvidia-396/
#2 0x00007ffff2879b0a in ?? () from /usr/lib/nvidia-396/
#3 0x00007fffead336a2 in ?? () from /usr/lib/nvidia-396/
#4 0x00007ffff7de767a in call_init (l=0x222a010, argc=argc@entry=1, argv=argv@entry=0x7fffffffd758, env=env@entry=0x7fffffffd768) at dl-init.c:58
#5 0x00007ffff7de77cb in call_init (env=0x7fffffffd768, argv=0x7fffffffd758, argc=1, l=) at dl-init.c:30
#6 _dl_init (main_map=main_map@entry=0x222a010, argc=1, argv=0x7fffffffd758, env=0x7fffffffd768) at dl-init.c:120
#7 0x00007ffff7dec8e2 in dl_open_worker (a=a@entry=0x7fffffffcb50) at dl-open.c:575
#8 0x00007ffff7de7564 in dl_catch_error (objname=objname@entry=0x7fffffffcb40, errstring=errstring@entry=0x7fffffffcb48, mallocedp=mallocedp@entry=0x7fffffffcb3f, operate=operate@entry=0x7ffff7dec4d0 <dl_open
worker>, args=args@entry=0x7fffffffcb50) at dl-error.c:187
#9 0x00007ffff7debda9 in _dl_open (file=0x19aa416 “”, mode=-2147483390, caller_dlopen=0x7ffff67988eb <dlopen+107>, nsid=-2, argc=, argv=, env=0x7fffffffd768) at dl-open.c
#10 0x00007ffff548ef09 in dlopen_doit (a=a@entry=0x7fffffffcd80) at dlopen.c:66
#11 0x00007ffff7de7564 in _dl_catch_error (objname=0x212fc30, errstring=0x212fc38, mallocedp=0x212fc28, operate=0x7ffff548eeb0 <dlopen_doit>, args=0x7fffffffcd80) at dl-error.c:187
#12 0x00007ffff548f571 in _dlerror_run (operate=operate@entry=0x7ffff548eeb0 <dlopen_doit>, args=args@entry=0x7fffffffcd80) at dlerror.c:163
#13 0x00007ffff548efa1 in __dlopen (file=, mode=) at dlopen.c:87
#14 0x00007ffff67988eb in dlopen () from /usr/local/NVIDIA-Nsight-Graphics-Linux/target/linux-desktop-nomad-glx-x64/
#15 0x000000000119efb5 in ?? ()
#16 0x000000000116670e in ?? ()
#17 0x00000000011681db in ?? ()
#18 0x0000000001168028 in ?? ()
#19 0x00000000011556a5 in ?? ()
#20 0x0000000000c5afdf in ?? ()
#21 0x0000000000450b49 in ?? ()
#22 0x00007ffff441e830 in __libc_start_main (main=0x450710, argc=1, argv=0x7fffffffd758, init=, fini=, rtld_fini=, stack_end=0x7fffffffd748) at …/csu/libc-start.c:29
#23 0x000000000045d4d1 in ?? ()
#24 0x00007fffffffd748 in ?? ()
#25 0x000000000000001c in ?? ()
#26 0x0000000000000001 in ?? ()
#27 0x00007fffffffdb94 in ?? ()
#28 0x0000000000000000 in ?? ()

There is zero issues with my drivers.Both glxgears and my OpenGL based apps run fine on that machine.But your Nsight just can’t see those processed,neither it is able to launch or connect to those.
My graphics drivers is 396.54,same as what the user above specified.But my hardware is Quadro P4000

Hi guys,

I cannot reproduce this on my local machine.
Can you try latest Linux driver (*.run file) downloaded from Nvidia official website? ppa drivers are not always guaranteed to work with Nsight Graphics.


Did you test it with the exact hardware I mentioned? The problem only seems to be occurring with the laptop version of the Quadro line of cards. I also tested it on another machine with a GTX 1080 and there it works just fine. Only difference is that it’s a Ubuntu 18.04 instead on my local machine with a Ubuntu 16.04.

Hi guys,

This seems driver related. Please re-install the latest Linux driver (*.run file) downloaded from Nvidia official website. We’ve found one local machine with the same issue, after re-installation of driver, the issue is gone.

Please note that, during installation of the driver:

  • When installer asks for whether to overwrite some libraries, please select “Overwrite”
  • Install 32-bit libraries

It really works with the drivers directly downloaded from the Nvidia website. I also needed to set nouveau.modeset=0 in my kernel start parameters. After that the debugger works like a charm. Thank you

Glad it works for you!
If you have any feedback about Nsight Graphics, feel free to let us know :)

codym_nv what version of the drivers do you expect us to install? I currently have 396.54 installed.
Now,I also downloaded driver 410.57 ,but I am getting error
“The distribution-provided pre-install script failed! Are you sure you want to continue?”

Another weird thing I noticed is drivers version numbering.I see in the list of the drivers on NVidia advanced driver search page,that 390 is more recent than 396. Is this a typo or what? Isn’t greater number supposed to be newer?

And the debugger doesn’t work also if I run on GTX 1070 which I put instead of P4000 to see if there is any difference.

Hi SasMaster,

390.87 is the latest Linux driver, 396 might be a beta one. 410.57 is the latest Linux driver for RTX 2080/2080Ti.

During installation, just ignore the error message: “The distribution-provided pre-install script failed! Are you sure you want to continue?” And continue.

codym_nv , but then I have another problem - See,I use also CUDA SDK. And gets removed from its location once I replace driver 396 with another one.And if I re-install CUDA afterwards, it installs the graphics driver which is bundled with it - in my case that’s CUDA 9.2 with driver 396. What can I do with it?

Hi SasMaster,

Can you try manually re-installing the exactly same version of driver that was bundled with CUDA? If you select the correct options during installation, graphics debugging should work fine.

Ok, I solved this one (Linux). So I purged all the nvidia stuff including CUDA SDK.vInstalled Graphics driver 410.57. Then re-installed CUDA 9.2 from .run file ,skipping bundled graphics driver.The debugger now works.

But, as I already published in another thread and got no answer,regarding NVIDIA NSIGHT plugin for Visual Studio - it crashes when running on latest Windows drivers and QUADRO P2000 (notebook) cards. We tried on several notebooks which come with this GPU version and the debugged application (same one we debug on linux with Linux debugger) starts up then once user tries to interact with NSIGHT GUI it freezes and leads to crash.

Hi SasMaster,

Glad it works for you on Linux.

About your issue on Nsight VSE, can you post a new thread in “Nsight, Visual Studio Edition” sub-forum?
By saying “it freezes and leads to crash”, did you mean target app freezes and crashes or host app(Visual Studio) ?
Please post your environment information, i.e., OS version, GPU model, graphics driver version, and steps to reproduce the issue.


Discard the last one,that’s my second user.It looks like your forums don’t allow to delete messages.

The visual studio freezes then crashes ,once I start interacting with the Nsight UI.
I put this issue already in Nsight,Visual Studio Edition.
The system is :Windows 10 pro. GPU: Quadro P2000 , OpenGL 4.5 core.