Nsight Monitor crash on 5.5

Hello,

I can’t use the latest version of Nsight because the monitor application keeps crashing on startup with this callstack:

Application: Nsight.Monitor.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.NullReferenceException
at .Nvda.Messaging.InterprocessMessageQueue.GetMessagesAvailableEvent(Nvda.Messaging.InterprocessMessageQueue*)
at .Nvda.Messaging.CoIpcMessenger.MessagingThread(Nvda.Messaging.CoIpcMessenger*)
at .Nvda.Messaging.CoIpcMessenger.MessagingThread_(Void*)

It first reports being connected to localhost but at the same time also reports that the connection has been terminated abnormally.
It’s a DX11 64 bit application running on Win10 Pro Build 16299.192

Any known workaround available?
Thanks!

Hi omniparagon,

I’m sorry for the problem you met.
Can you provide more information please?

  • Driver info
  • Did the issue happen with all samples including OpenGL samples?
  • can we have your sample please? then we can identify the issue quickly.

Thanks,
Letitia

Driver version is 388.71 on a GTX 960.

Apologies, it’s a closed source sample I can’t share it. It did work on version 5.3.
I don’t currently have OpenGL samples to try it on, can you please point me to one?

Regards

Hi omniparagon,

Can you please try the following samples at your convenience?

If the issue happened with the sdk samples, please tell me the steps to repro it.

Thanks,
Letitia

The same problem happens when I try the InstancingFX11 sample. I just built a Release win32 version from the 2015 solution, changed it to use the windows sdk 10.0.15063.0, ran it once to see that it works and then tried to start it with Nsight using “Start Graphics Debugging” from VS. Same problem as above.

Hi omniparagon,

I tried the sample - InstancingFX11 as Release|win32 locally, no crash, it ran smoothly with nsight.
My configuration as below:

Can you please check your configuration again and try it again please?

Thanks,
Letitia

Hi Letitia,

Unfortunately I don’t have other configurations to try it on but I can confirm the issue is 100% reproducible with the configuration I’ve mentioned previously. Happy to help with any other info as I’ve not been able to use Nsight since 5.3.

There is also a frequent crash of VS on shutdown due to having Nsight installed, since 5.3. The crash happens in C:\Program Files (x86)\NVIDIA Corporation\Nsight Visual Studio Edition 5.5\Host\Common\Qt5CoreNvda.dll

Regards

Hi omniparagon,

I’ll upgrade the OS to Win10 Pro Build 16299.192, and then check it again.

As far as the issue of the frequent crash of VS on shutdown, we’ve already had an internal bug to track it.
Thanks for your feedback.

Letitia

Hi,

I experience the same issue on Windows 7 SP1, using NVIDIA NSight 5.5.0.18014.

Nsight monitor crash when attempting Graphics Debugging on an OpenGL 3.2 application.

The error message (null reference exception) and call stack exactly matches what omniparagon reported above.

Hi guillaume.andrieu,

I’m sorry for the problem you met. Can you provide more information please?

  • Did the issue happen with other API samples? such as DX SDK samples.
  • Did the issue happen on other platforms? such as WIN10.
  • Did the issue happen with all OpenGL samples?
  • Can we have your samples please? then we can identify the issue quickly.

Thanks,
Letitia

Hi Letitia,

Note I have since downgraded to NVIDIA NSight 5.3.0.17162, and do not encounter the crash using this earlier version.

To capture additional information on the crash, I reinstalled NVIDIA NSight 5.5.0.18014.
The results are as follows:

  • DX SDK sample

I ran the following samples from https://github.com/walbourn/directx-sdk-samples :
InstancingFX11_2013.vcxproj, InstancingFX11_2015.vcxproj, SimpleSample11_2013.vcxproj

All 3 crash when starting Nsight Graphics Debugging, with similar messages:

Application: Nsight.Monitor.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.NullReferenceException
   at <Module>.Nvda.Messaging.InterprocessMessageQueue.GetMessagesAvailableEvent(Nvda.Messaging.InterprocessMessageQueue*)
   at <Module>.Nvda.Messaging.CoIpcMessenger.MessagingThread(Nvda.Messaging.CoIpcMessenger*)
   at <Module>.Nvda.Messaging.CoIpcMessenger.MessagingThread_(Void*)
Faulting application name: Nsight.Monitor.exe, version: 5.5.0.18014, time stamp: 0x5a5bff56
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x000007fe8ec9d27c
Faulting process id: 0x28f8
Faulting application start time: 0x01d39c17677a6637
Faulting application path: S:\Programs\X86\NVIDIA Corporation\Nsight Visual Studio Edition 5.5\Monitor\Common\Nsight.Monitor.exe
Faulting module path: unknown
Report Id: a751c057-080a-11e8-8800-bc305bae2dff
  • Running on Windows 10

I cannot test this due to lack of Win10 machine.
The original report from omniparagon shows the same issue occurs on Windows 10 (same exception, same stack) which strongly suggest the issue is NOT specific to Win7 SP1.

  • OpenGL samples

I tested 2 OpenGL applications : a basic OpenGL hello world, and a larger proprietary OpenGL 3.2 application.
The basic hello world sample can be found here:

opengl_hello_world_2013.7z, Expiration: Tuesday, April 3, 2018 1:22 PM, https://framadrop.org/r/fdgEl9-aRH#cePJfQz6uJVtyO7oYehWjRkcvOYCNMANk/Y3KH4Vq8g=

If you’d like me to test other samples, could you please tell which specific ones you need me to try, and where to obtain them?

  • Additional system details:

Operating System: Win7 SP1
Graphics card: NVIDIA Quadro K series
Graphics driver: NVIDIA 385.41
Antivirus: Trend Micro OfficeScan 12.0.4430 SP1

Regards,

Guillaume

Hi guillaume.andrieu,

I received your email which didn’t show in the form.
I checked the sample - InstancingFX11 (Release|win32) on WIN7 platform, no issues.

  • Did the issue of InstancingFX11 happen with Nsight 5.3?
  • Which version of Visual Studio did you use? VS2013,VS2015 or VS2017?
  • Can you update the driver to the latest version and then check it again?
  • Can you halt the antivirus software temporarily and then check it again?
  • If the issue still happened, can you re-check it on another “clearer” machine please? Just install OS, driver, VS and nsight, and then check it again.For we never met the issue before, and we cannot reproduce the issue locally.

Thanks,
Letitia

Hi Letitia,

I am using VS2013 and VS2017 2015, and experience NSight Monitor crashes using both IDEs.

Is the Win7 machine you use to reproduce up to date?
I wonder if that is related to recent Windows security updates issued by Microsoft (rel to Meltdown/Spectre).

  • NVIDIA Nsight 5.3 + InstancingFX11

I will downgrade to 5.3 again and try this.

Actually I’ll keep 5.3 on this machine for a while, since I’m going to need NSight’s Graphics Debugging, and because reinstalling a different NSIght version is a relatively long process.

  • NVIDIA Driver update

As you suggested I upgraded my drivers to the latest for my card:
Graphics driver: NVIDIA R390 U2 (390.77) WHQL - Quadro Desktop

Crashes persist after upgrading to version 390.77, in both OpenGL hello world (release|win32), and DX InstancingFX11 (release|win32) samples.

  • Software antivirus

That’s not under my control, I will need to request that IT temporarily disable my AV to try this.

  • Clean machine

I am a bit too busy to setup a brand new machine, I hoped these tests and crash dump I provided would be enough to investigate.
If I get the chance, I’ll try setting up NSight on another Win7 machine that’s already installed.

Guillaume

Update:

Using NVIDIA NSight 5.3.0.17162, I can use Grahpics Debugging with Sample DX InstancingFX11 (release|win32), capture a frame a play a bit with frame replay. No crash.

Guillaume

I installed NVIDIA NSight 5.5.18014 on a different machine, and tested sample opengl_hello_world with Visual Studio 2010.
It crashed too.

System details:

Operating System: Win7 SP1
Graphics card: NVIDIA GTX 460M
Graphics driver: NVIDIA 378.92

So far NSight 5.5 always crash forme. I tried both an OpenGL sample, an DirectX sample. I have tested this across 2 machines with different graphics cards (Quadro/GeForce), with overall 3 driver versions, 3 Visual Studio versions (2010/2013/2015).

Hi guillaume.andrieu,

I got the problem, Nsight 5.4 and higher version don’t support GTX 460M(Fermi GPU), please refer to the release notes for detailed information, links as below:
http://docs.nvidia.com/nsight-visual-studio-edition/5.4/Content/Release_Notes_Main.htm
http://docs.nvidia.com/nsight-visual-studio-edition/5.5/Content/Release_Notes_Main.htm

Can you please try it again with Kepler or higher GPU?

Thanks,
Letitia

Hi letitia,

The first machine I tried this with actually has a NVIDIA Quadro K5200.
Quadro K5000 series seems to use the Kepler architecture http://www.nvidia.com/object/quadro-k5000.html

So I already tried that on a Kepler, and got the same crash.

Edit:
Actually if you read the earlier message from omniparagon, he mentions the same crash can be seen with
“Driver version is 388.71 on a GTX 960” (Maxell, ie post-Kepler).
So there are 2 people, seeing the same crash on 2 machine with Kepler and Maxwell cards.

Guillaume

I involved IT to disable the Trend Micro antivirus.

The crash can still be reproduced without AV running.

Since I reproduced the crash again, I took the occasion to capture more information in a debugger.

If it can help, I can also provide a copy of the dll/module, and an event capture done with ProcMon.

Visual Studio main info on crash:

Module Information:
Version: 5.05.0.18014
Original Location: S:\Programs\X86\NVIDIA Corporation\Nsight Visual Studio Edition 5.5\Monitor\Common\Nvda.Messaging.Interop.dll

Visual Studio output view:

An unhandled exception of type 'System.NullReferenceException' occurred in Nvda.Messaging.Interop.dll
Additional information: Object reference not set to an instance of an object.

Visual Studio callstack view:

>	Nvda.Messaging.Interop.dll!<Module>.Nvda.Messaging.InterprocessMessageQueue.GetMessagesAvailableEvent()	Unknown
 	[Native to Managed Transition]	
 	[Managed to Native Transition]	
 	Nvda.Messaging.Interop.dll!<Module>.Nvda.Messaging.CoIpcMessenger.MessagingThread()	Unknown
 	Nvda.Messaging.Interop.dll!<Module>.Nvda.Messaging.CoIpcMessenger.MessagingThread_(void* arg)	Unknown

Module/DLL md5 and sha1 checksums:

1c6cdfba920c89ca708f4e0640424f81dd7e7130 Nvda.Messaging.Interop.dll
fc7d18cdbe282dbaf1aaa88c31a5d648 Nvda.Messaging.Interop.dll

Hi,

I’ve got the same issue with the same stack trace every time I try to do “Graphics Debugging” on an OpenGL application. I have a GTX 1060 (6GB), Win10, VS2017.

Has there been any progress on this or do I need to downgrade to 5.3 which appears to be the last working version?

There’s been no progress recently, so I’d suggest downgrading for now.

The latest I heard from letitia is that Fermi GPU are not supported, but that doesn’t help since newer card are affected.