Nsight 5.0 very unstable


I have a problems with a Nsight 5.0.

“Graphics debugging” works almost never. It’s runs only ~1 of 10 launches of application. Usually the app launches without Nsight overlay, and “Pause and Capture” not available. So I killing Nsight monitor and relaunch it again, usually on ~10 time it finally works. But it also shows error like a “Nsight required OpenGL 3.3 for work. Current version: (unavailable)” before create the window with a FrameDebugger.

“Performance analysis” (OpenGL trace) absolutely doesn’t work. Usually it crashes with “save minidump” dialog. In other cases it launch, but when I press “Stop” in “Capture Control” it creates an empty report.

  • I have the last Nvidia drivers (358.87) for GeForce GTX 660.
  • It’s a default desktop PC without any Optimus/Hybrid graphics features.
  • Windows 7 x64, Visual Studio 2013, the app is also x64.
  • app uses OpenGL 4.2
  • Nsight 4.7 works perfect on that PC
  • I already tried “full/fresh reinstallation” for Nsight and Nvidia Drivers
  • I have 3 GPU in that PC: Intel IGPU, Nvidia GTX 660 and Radeon HD 5700. I tried disable ATI and Intel, but that doesn’t helps

I can send minidupms and DxDiag logs in PM.



Sorry to hear about your instability. You mentioned that you’re using 358.87 – note that the officially supported driver version for Nsight 5.0 is 355.98. Would you give that driver a try? If you don’t have any success, feel free to send me a minidump via PM and I’ll take a look.



I’m having similar problems getting NSight 5.0 to work as have been reported in this and another post.

App is built with VS Enterprise 2015, MFC, OpenGL 4.4 or for those without a modern graphics card, OpenGL 1.1. I’ve tried both the recommended 355.98 drivers and the latest 358.91 drivers. Neither works.
App runs standalone or from the debugger in Visual Studio Enterprise 2015.

Trying to run NSight 5 remotely from a notebook with either an Intel HD-4600 or ATI R6 card, Nsight doesn’t work on either a new Dell 16 core Workstation with a Quadro K4200 or on a 2 year old HP Envy Notebook with Optimus/nVidia GeForce 740M card. No luck.

The HUD has never come up. Once on the Dell/Quadro running remotely from the Toshiba-Intel laptop, I did see the Shaders window come up on the remote notebook. By contrast the HP_ATI notebook’s CodeXL software does show shaders loaded, contents of Texture buffer, OpenGL state variables, etc when the app runs.

I’ve launched the NSight Monitor on the remote machine and it says it is configured properly. App comes up and crashes on the Notebook with the Optimus/GeoForce 740M card. Dell/Quadro machine runs the app but nothing shows up on the remote notebook nSight windows, although I did see the Shader window populate on the remote once.

Documentation in nSight 5 isn’t clear on how to get the HUD to come up. Does it come up automatically if nSIght is working?

Thanks for any information or help!

Addendum to previous post.

Current OS on all machines is Windows 10. Win 10 Pro on Dell Workstation with laptops on Win 10 Home. Latest updates applied on all.

Started out trying this with Windows 7 SP1 PRO all latest hot fixes. Ended up upgrading all machines to Windows 10 to see if that would help. It didn’t. Laptops are on Windows 10 Home. Dell workstation is on Windows 10 Pro. All latest updates applied.


Addendum to previous posts.

App builds in both x64 and Win32. Tried both builds, neither works.


Hi EAcreeGCC,

I want to confirm something:

  • the Nsight version is the same on all your machines
  • Nsight don’t support Win10 Hybrid Graphics system right now, hence please try on desktop machine

Please choose a desktop machine, make sure your app runs smoothly without Nsight, I mean double click it or run it under the cmd. Then open your solution on that machine, make sure Nsight’s Configuration has been set properly, especially the “Working directory”, set the target machine as localhost, then try to launch your sample by click ‘Nsight’->‘Start Graphics Debugging’. If everything works as expected, you should see your app with HUD on the desktop machine.

Let us try to make your app runs with Nsight on one machine at first.

PS, please begin a new thread about your issue, otherwise it might be mixed with many different issues in one thread.