Nsight 5.4 on Visual Studio 2017 hangs when launching the debugger

I recently upgraded from Visual Studio 2015 Community to Visual Studio 2017 Community and Nsight 5.4, and I can no longer use Nsight to debug my OpenGL project.

When I run Nsight, it creates a command prompt and successfully attaches to the Nsight monitor, but it doesn’t execute any code after that. If I break the process using Visual Studio, the only active thread is “[0] Graphics” and the stack frame is “[0] No current gpu coordinate.” No disassembly is available.

I’ve tried reinstalling Visual Studio 2017 and Nsight 5.4 twice, but I can’t seem to get past the black command prompt (no code is executed). My GPU is a GTX 1080, and my driver version is 387.92.
Monitor.log (49.6 KB)
Vsip.log (49.3 KB)
nsight-hang.png

Hi,

I’m sorry for the problem you met, please provide more information for investigating the problem:

  • When Visual Studio 2015 Community was used, can you debug the OpenGL project with Nsight 5.4? Will the black command prompt show up after the sample was launched with nsight?
  • Can we have your sample to do some local repro, then we can identify the crash quickly?

Thanks,
Letitia

I seem to be having a very similar problem albeit with a different setup. When I start graphics debugging I see the prompt telling me that I have successfully connected to the nsight monitor (I am connecting to localhost) but then nothing. The process is still running but if I break manually, very much like the OP I see a single thread called ‘Graphics’, its location is ‘Unknown - [0] No current gpu coordinate’.

My setup is:

  • Windows 10 Pro
  • Visual Studio Professional 2015, version 14.0.25420.01 Update 3
  • Nsight 5.4, build no. 5.4.0.17240
  • The app I am trying to profile is DirectX based, not OpenGL (in fact it is the UE4.16.3 Nvidia Hairworks integration
  • GTX 1080 Ti
  • Driver version: 385.28

Is there anything else I could provide that could help diagnose?

I haven’t tested running Nsight 5.4 with Visual Studio 2015. When I get a moment I may try that out, but based on what Hecatonchires just posted, it seems more ilke a GTX 1080 issue than a Visual Studio one.

I ran my project on another computer which had a GTX 960, Visual Studio 2017, and Nsight 5.4 and it worked fine. The only differences between the two computers are:

  • I upgraded both Visual Studio and Nsight on my GTX 1080 machine, where as on the GTX 960 machine it was a fresh install of both.
  • The GPUs are different between both machines.

To clarify, I can’t Nsight any project on my GTX 1080 machine, not just the one I posted.

Hi cedega,

Can you please try it again?

  • Uninstall Nsight and install it again, then try to launch the sample again.
  • Or just insert the GTX 1080 GPU to the machine where the GTX 960 is inserted, I want to check if the test environment on the machine(GTX 1080 inserted) caused the issue.

Thanks,
Letitia

Hi Hecatonchires,

Thanks for your feedback, can you provide more information about the issue please?

  • Did the sample run fine without nsight?
  • Can you please try it again using the latest version of graphics driver?
  • Did nsight work fine with other samples?
  • Can we have your sample to reproduce the issue? please upload it to the path https://ftpservices.nvidia.com
    Username: CVLKEOUCOT
    Password: (3{CDt]J

Thanks,
Letitia

I’m afraid I wont have an opportunity to switch graphics cards for some time, but if I do I’ll post an update.

On the bright side, I downgraded to Nsight 5.3 and it works perfectly.

(As a test, I uninstalled 5.3 after and reinstalled 5.4. Still broken, but at least 5.3 works consistently)

Hi cedega,

Thanks for your feedback.

  • I tried an internal nsight build & VS2017, it works fine with OpenGL samples.Please wait for the release build and check it again.
  • Or can you provide the sample to us if it’s convenient for you, then we can identify the issue quickly?
  • If you test it again after switch graphics cards later, please tell us the update, we’ll do more research for it.

Thanks,
Letitia

Hi Letita,

in answer to your questions:

  • Yes, the sample runs fine without nsight
  • I updated my drivers to version 388.00 and still see the sam behaviour.
  • I see the same behaviour from nsight with every sample that I try, including those that have previously worked just fine.
  • I also tried swapping out the 1080 Ti for a GTX 980, and saw the same behaviour.
  • The sample I was using was actually an Nvidia sample https://github.com/NvPhysX/UnrealEngine, specifically I was using the branch tagged as 4.16.3-HairWorks1.3 and the sample Unreal project supplied. However I also downloaded the DX11 tutorial projects for a super simple project and these also show the same behaviour.

same problem here with a fresh install Nsight_5.4.0.17229 with a 1060 GPU on windows 7 + VS2017
Nsight cuda debugging , performance analysis work fine, and connect to monitor correclty
but nsight graphic debugging crashes the monitor after connection, no log

Hi Hecatonchires,

Thanks for your feedback, I checked a DXSDK sample - Direct3D11Tutorials\Tutorial01 with an internal nsight build & VS2017, it works fine with nsight.
If the issue occurred all the time, please wait for the release nsight build and try it again.

Thanks,
Letitia

Hi westerrr,

Thanks for your feedback, can you provide more information about the problem please?

  • Did the issue happen on WIN10 + VS2017?
  • Did the issue happen with any sample(DX11, OpenGL or others)?
  • Is the test machine a desktop or laptop machine?
  • Can you provide your sample to us then we can identify the issue quickly?

Thanks,
Letitia

Same problem with Hecatonchires. Nothing happened after I connected to the localhost. My build is Win7 + VS 2015 + NSight 5.2.

Hi kelm,

Can you try the latest release version - Nsight 5.4 and check it again please?
If you still encounter the problem, please tell us.

Thanks,
Letitia

Hi letitia,

I tried the Nsight 5.4 and also updated my driver version to 388.13, but doesn’t work… show nothing after clicking “Start Graphics Debugging”

Hi kelm,

Thanks for your feedback. Can you provide more information please?

  • Did the sample run fine without nsight?
  • Did the issue happen with any other samples?
  • the version of OS platform
  • Was your machine desktop or laptop? If laptop, did it support hybrid mode?
  • Can you provide the sample to us then we can identify the issue quickly?

Thanks,
Letitia

Hi letitia,

Thanks for the reply! I figured out it was the permission problem! It was not about the Nsight itself! My working environment caused this. I really appreciate your help!

Hi Kelm, I ran into the same problem as you do. you say it’s all about permission, any details ? is it about setttings in antivirus software?