Crash when initiating Graphics Debugging in 5.6

I’ve had this problem for a while now on my PC, I’m unsure as to the cause and I could really do with it working.

I can run NSIGHT against my game on other PCs here and my PC at work just fine, but my primary dev machine at home fails every time.

My machine is pretty standard:
Windows 10 (fully updated)
Visual Studio 2015 (fully updated)
NSight 5.6 (I was having this problem in previous 5.5 versions too).
NVIDIA GTX 980

I get the same exact problem just trying to debug the default DX11 sample app template from Visual Studio. Both apps tested are D3D11. Pretty small simple game and the sample app.

When I click to initiate Graphics Debugging I get a strange partially rendered window pop up (it has nothing to do with my game/sample, it’s NSIGHT), I see the process for my game launch but it never executes any code. Then Visual Studio crashes, restarts itself, but I can’t build because some NV background processes have exclusive handles locked on to my .exe:
http://martincaine.com/files/forums/nvidia/2018-06-13_window.png

I’ve set the log settings to trace, and grabbed this log from:
http://martincaine.com/files/forums/nvidia/2018-06-13_Nsight_Monitor.log

The following details come from the Application Error that gets logged in Event Viewer:

Faulting application name: devenv.exe, version: 14.0.25420.1, time stamp: 0x57685d85
Faulting module name: Nvda.Graphics.FrameDebuggerUi.Common.Native.dll, version: 0.0.0.0, time stamp: 0x5b0a24ef
Exception code: 0xc0000005
Fault offset: 0x001630b8
Faulting process ID: 0x2e28
Faulting application start time: 0x01d402ea3b796e2b
Faulting application path: C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\devenv.exe
Faulting module path: C:\Program Files (x86)\NVIDIA Corporation\Nsight Visual Studio Edition 5.6\Host\Common\Nvda.Graphics.FrameDebuggerUi.Common.Native.dll
Report ID: abf46650-56bc-4b62-94e1-9463bb39f52c
Faulting package full name: 
Faulting package-relative application ID:

This Windows Error Report is also created, but I don’t see any .dmp or anything else in there:
http://martincaine.com/files/forums/nvidia/2018-06-13_Report.wer

I assume this has something to do with something I have installed, perhaps on my system or within Visual Studio itself. I just can’t figure out why it’s crashing and hope someone else might spot something or have experienced something similar.

Hi,

What version of graphics driver are you using?
Can you try uninstalling the driver and installing it again? Make sure you reboot the machine after uninstallation and installation.

I’m on 398.11 right now. I’ve been having this problem for a few months with the older version of NSIGHT and also this latest 5.6 release, generally always using the absolute latest driver from Geforce Experience.

I’ll try a complete uninstall of the driver and reinstall though.

Tried that, made no difference.

Completely removed graphics driver, geforce experience, and nsight. Rebooted. Installed latest driver (with ‘clean’ option). Rebooted. Installed Nsight. Rebooted.

Same problem. It brings up that weird window over the top of Visual Studio which is only partially painted, then crashes and restarts visual studio a few seconds later.

Hi Martin,

Given that you’re seeing this problem on only one machine, the best way to try to debug it would be to see if it manifests on https://developer.nvidia.com/nsight-graphics on that machine. That tells a number of things – whether it is Visual Studio specific or machine specific. If you do crash with Nsight Graphics, it speaks to a machine issue. In the case that you do crash, I would suggest filing a crash report (the popup should be automatic) and someone can take a look on our side and hopefully get back to you if you include your email on it. If you don’t crash, it could indicate being specific to the Visual Studio integration or that the bug is already fixed, as Nsight Graphics comes from a slightly newer codeline than Nsight VSE does. Another option is to attach an instance of Visual Studio to one in which you try the tool and find a crash, then save a crash dump manually via Debug > Save Dump As. You can then send me a private message with a link to the dump (with whatever your preferred cloud file sharing app is).

Hope this is helpful,

Dan

Thanks Dan,

I had already downloaded NSIGHT Graphics but haven’t tried it yet. I’ll give that a try later today and see how it goes.

I tried all sorts last night to see if I could get it to work:

  • Unplugged my Oculus Rift and all accessories
  • Plugged in my second monitor (I remember I was using this last time I used NSight)
  • Disabled all the VS Extensions I don’t use and even uninstalled some.
  • Disabled Windows Defender
  • Shut down as many background processes and services as I could

Nothing made any difference though.

I never got round to trying NSight Graphics because I remembered I could use Nsight HUD.

Weirdly, if I right click my game executable and ‘Launch with NSight HUD’ it works fine. Same for the sample app, and for a game on Steam I tried.

The crash when Launching Graphics Debugging from Visual Studio still persists however.

I did attach VS during the crash and saved out a dump. I’ll drop you a PM with the link once it’s finished zipping up and is uploaded.

Thanks :)