not able to connect to nsight monitor after update to nsight VS 3.0

Hello community,

I just updated recently from nsight 2.2 to 3.0 (3.0.0.13150). Since the update I not able to connect to nsight monitor any mor. When I’m reinstalling nsight 2.2 everything works fine.
I’m working on Win7 64Bit having a quadro 410 & a GTS450 plugged in. Furthermore I’m working with VS2010.
The message I receiving start in the analyser for example is: Connection to the Nsight monitor on ‘localhost’ failed. Please make sure the monitor is running on the target machine and the security settings match.
Oh sorry I forgot to mention that I’m debugging local.

I tried to follow the instructions Jeff Davis gave in:
https://devtalk.nvidia.com/default/topic/529718/start-cuda-debugging-greyed-out/

But actually I’m not really familiar with nsights log-syntax.
First line of the nsight-log (not monitor) says: CommunicationChannel exception : System.ServiceModel.ProtocolException: The requested upgrade is not supported by ‘net.tcp://localhost:8000/Nsight’. This could be due to mismatched bindings (for example security enabled on the client and not on the server).

Of course I checked these settings at first, there all the same like for nsight 2.2

Any suggestion?

Many tnx in advance.
Greg

Hi Greg,

So you are uninstalling 2.2 and installing 3.0 on the same machine right? A couple of questions to verify things:

  1. When you uninstall 2.2, could you make sure the directory is removed "C:\Program Files (x86)\NVIDIA Corporation\Nsight Visual Studio Edition 2.2" before installing 3.0?
  2. Run the monitor from the newly created directory from the 3.0 installer, and check the security options in the Monitor settings (point #3). Make sure Windows firewall allows access to port 8000
  3. Run VS and double check that the security 'host' options match the settings from the previous step

Hi rafi,

Thank you for your answer. To your question, yes that’s the same machine.

I tried all the steps you suggested in your in comment already, however I tried it once again.
I made sure the previous installation was delayed properly. My firewall is turned off by default.
I verified the setting. I mean there not much you can set. I changed the port to port 80, but the result is still the same.
There is one issue let me make a pause.
When I’m moving the cursor over tray-icon of nsight monitor is shows me the name of my pc followed by an IP and my current selected port. This is not the address of my localhost, but one of my nic’s.
I compared this with version 2.2, were the localhost IP is not displayed as well, but I’m able to establish a connection nevertheless.

Best regards
greg

I see, you have multiple NICs.
May I ask you to try the following with a project open:

  1. Nsight -> Start CUDA Debugging (if it connects, stop debugging)
  2. Nsight -> Windows -> System info
  3. Nsight -> Start Performance Analysis...

Do they all fail to connect?

As a potential workaround, you can change the ‘connection name’ under the Nsight host settingsto be the IP that the monitor displays. Does this workaround make things work on 3.0?

Thanks

Hello rafi,

thank you for helping me to solve this problem. I’m sorry for the delay I was busy to solve other issues.
However, steps 1-3 fail to connect. Your suggested workaround doesn’t work as well.
I made a screenshot, please take a look:

any other suggestions?

thanks

using nsight 2.2 it’s working quite well:

cheers greg

Issue solved:
secure connection must be in enabled in nsight 3.0 while must not in nsight 2.2 to be able to connect to the monitor (at least in my case).

tnx anyhow.

greg

Hello Greg,

Interesting, this may not be useful anymore, but would like to see if there is some issue here that we need to fix. On both of the screenshots, you were showing the Monitor options, what was set (security settings) for the host? (under the Nsight menu -> Options…).
If you turn security to “False” on both, VS and the monitor (the monitor needs to be restarted), are you still not able to connect?

Thanks, and sorry for that pain…