Problem connecting to Monitor over SSH Tunnel


i have a SSH Tunnel established between my development machine and the machine containing the GPU i want to work with (Forwarding local port 8000 to the port 8000 on the remote machine).
I am using Nsight 3.0 with VS 2010.
The tunnel works properly because i can click the “Start Performance Analysis…” command in the Nsight menu, the Performance Analysis option dialog opens, a popup indicates that connection to Monitor was established, the connection indicator is green and also showing the available device on my remote computer. However nothing else works. I can not start the actual analysis, if i click the Launch button, a popup error message says “Missing file on system: PathToMyExecutable”, PathToMyExecutable is the correct path to my executable and of coarse the executable exists.
Also “Start CUDA Debugging” command and the “System Info” command produce a popup “Connection to Nsight Monitor on ‘NameOfMyDevelopementMachine’ failed.”.

To me this looks like a bug in Nsight. Please assist in finding out what is causing these problems and finding a solution.

Thank you.

Is your tunnel able to open up multiple simultaneous connections over port 8000?

Hi Jeff,
yes, multiple connections on the same port work without a problem (i also have another services like remote desktop access and SVN access that go over this SSH tunnel, just on different ports and i have no problems with these services).
I did some more test and realized that the “System Info” also doesn’t work if i am connecting without a tunnel inside the same network segment - it is always trying to connect to the local Monitor no matter what “Connection name” i set inside Nsight User Setting dialog.
CUDA Debugging and Performance Analysis works properly when connecting over local network so we can be sure that the Monitor on the remote machine is working properly.

I made a few more experiments. I have set up the tunnel on a third machine and with this setup everything works (except “System Information” - see previous post).
My conclusion is that if Nsight sees that the configures connection is a connection to the machine it is running on it makes the assumption that the monitor is also running on the same machine which in this case is not true.
I can understand the benefit (for example you can skip the file synchronization if the assumption is correct) but it would be nice if Nsight did check if the Monitor it is connecting to is indeed a local monitor and not blindly assumed it.

Ah yes, Nsight assumes that connections to “localhost” are local debugging sessions. Let me look into this.