Nsight Compute fail to connect in Windows: Could not initialize command line profiler communication

Context
Nsight Compute version: Version 2023.1.0.0 (build 32451174) (public-release)
OS: Windows10
NVIDIA Driver version: 537.13

Issue:
when I launched the Nsight Compute and try to launch the profilem, it report the following error
image
It used to work well but somehow it failed to launch the profile. I try to extend port range but it doesn’t work.
I find a similiar post about the problem. I’ve update my Driver according to the post but it doesn’t help.
So what should I do? the error log says i should update the firewall setting, can someone tell me how to solve it ?

1 Like

Just to double check, you’re running a local windows GUI and trying to profile on the same local Windows machines. Is that correct? If so, this does look like a firewall issue. Can you check your settings to ensure that you allow local connections? Is it possible that you declined a connection when it first ran and now it’s blocked? Checking what’s allowed and blocked may reveal some information.

I think it might have something to do with windows. Nsight Compute can work now and I did nothing. Anyway, thank for your help :)

I got the same problem on my Win10 System with

  • Microsoft Visual Studio Community 2022 (64-Bit) - Current Version 17.7.4
  • NVIDIA Nsight Visual Studio Edition - 2023.3.0.23248
  • NVIDIA Nsight Visual Studio Edition - CUDA support - 2023.3.0.23248

CUDA Driver Version 545.92
CUDA Version 12.3

Firewall: All Ports for Nsight are open.
It was my first try to run Nsight for Visual Studio 2022 on this system. The above message always appears when I try to launch Nsight on my Application.

SOLUTION worked for me:
In GUI for NVIDIA NSight Compute Window => Menu “Tools” => “Options (F7)” under Section “Connection” I changed two settings:
first: the Base Port for “Target Connection Properties” from 49152 to 47152
second: the Base Prot for “Host Connection Properties” form 50152 to 48152
(shift of -2000 port to reach an port-range)
Guess the default port ranges were already occupied in my system.

5 Likes

Thanks for sharing the solution here.

1 Like