Hitting "Profile in NVIDIA Nsight Compute" in Visual Profiler always returns error message "Nsight Compute failed to generate report"

Since updating to Windows 10, I haven’t been able to get the extended analysis tools in the Visual Profiler to work. I am running the profiler as administrator, have performance counter access enabled for all users, and there is no issue with my code. I’ve tried and failed to find any references to the exact error message that I see. Does anyone know how to fix this?

Hi, Can you please provide more information like

  1. Toolkit version you are using
  2. Error message from Visual Profiler console
  3. Location of Nsight Compute install directory, location of ncu.exe?
  4. Does Nsight Compute command line (ncu.exe) work independently outside Visual Profiler?
  5. Is ncu.exe present in PATH environment?

Certainly, and thanks for the reply.

  1. Cuda version is 11.0 Update 1.

  2. The output from the console that does not come from my code is:
    ==PROF== Connected to process 11104 (C:\TFS\GpuTester.exe)
    ==PROF== Disconnected from process 11104
    ==WARNING== No kernels were profiled.
    ==WARNING== Profiling kernels launched by child processes requires the --target-processes all option.

  3. C:\Program Files\NVIDIA Corporation\Nsight Compute 2020.1.2\target\windows-desktop-win7-x64
    I did not change anything from the defaults during installation
    I also tried installing 2020.2.1, with no change in behavior.

  4. Yes, I can successfully run ncu.exe from the command line with the same test application

  5. Yes, ncu.exe is included in the path.

Thanks for the details.

This warning in #2 looks suspicious to me.
==WARNING== Profiling kernels launched by child processes requires the --target-processes all option.

  1. Yes, I can successfully run ncu.exe from the command line with the same test application

Are you running ncu.exe with “–target-processes all” option from command line? Can you please confirm


Thanks,
Ramesh Gunjal

Yesterday, I ran simply “ncu C:\TFS\GpuTester.exe”. I just tried adding --target-processes all and there appears to be no change in behavior. My test app does not spawn any additional processes - it’s just a basic command line app.

Out of curiosity, I also tried setting ncu.exe to run as administrator, but that had no effect on the Visual Profiler.