Nsight Visual Studio Edition 5.2.0 RC2 skips breakpoints

I am trying to debug a CUDA application using Nsight, but it fails to stop at any of the breakpoints that I set. The application compiles and runs without error. I also experience the same problem with the CUDA samples (matrixMul for example).

My setup:

  • Win 7 x64
  • CUDA 8
  • Visual Studio 2015 Update 3
  • NVIDIA driver 373.06
  • 2 GPUs (GTX 1080 & GTX 690)
  • Generate GPU Debug Information: Yes (-G)
  • Running via Nsight -> Start CUDA Debugging

The issue occurs regardless of which GPU I select (side note: CUDA debugging on the GTX 690 worked at some point in the past with older versions of CUDA/Nsight).

Given that this is occurring with the CUDA samples, I’m not sure if it’s a simple mistake on my part, an unsupported combination of software, or a bug in 5.2.0 RC?


AFAIK the Nsight 5.2 doesn’t work well with Pascal cards on windows 10 and 7 because of the driver’s issue, but the GTX 690 should work, could you please try the latest driver and Nisght?

Best Regards

I already have the latest version of Nsight installed ( so I installed the latest driver (375.70). However, the problem still persists, for both the GTX 1080 and the GTX 690. Enabling or disabling CUDA Memory Checker makes no difference.

I also tried debugging the GTX 690 using Visual Studio 2013 and CUDA 7.5, but had no luck…

Currently neither of the GPUs are attached to a display (it is driven using the iGPU on the Intel i7) - perhaps this is a factor?

I don’t remember making any changes to my Nsight settings, but I’ve attached the current config just in case there’s something amiss there.

Hi phw89,

Could you try to use the CUDA_VISIBLE_DEVICES to let the nsight use GTX 690, it should work with kepler cards,
I just find out that GTX 690 is a dual core card, I think you can disable the SLI in NVIDIA control panel and try to debug on it again.

Best Regard

Unfortunately setting CUDA_VISIBLE_DEVICES to only one of the GTX 690 cores made no difference. I am unsure what you mean regarding disabling SLI? My understanding is that the GTX 690 contains two cores, but they are not joined via SLI. Neither is the GTX 1080 and GTX 690 connected via SLI.

Quick update: The latest version of Nsight ( and the NVIDIA Driver (375.95) seem to have solved the problem :)