Nsight unresponsding to break points

I have 640GT card, windows 7, visual studio 8 service package 1,Nsight Edition 2.2 but when I run Nsight debugging tool its excuting the program but doesnt stop on any of my break points, what do I miss?

thank you

Which graphics driver are you using, and which version of Nsight 2.2 (Nsight Menu–>Help–>About)?

graphic driver 306.94, build 2.2.0.12313
it also adds There is no source code available for the current location. for the Nsight run and stops the debugging (I re installed Nsight with the additional toolkit now so now it gives me this message about breaking points)

Is this for CUDA debugging or graphics debugging? If its CUDA, have you tried the CUDA samples?

It’s cuda debugger and I get the same problem on samples

Hi,

Just making sure we have everything setup right and some questions:

  1. When you mention Visual Studio 8, are you referring to Visual Studio 2008? (VC 8 is Visual Studio 2005 which Nsight does not support)
  2. Are you selecting Nsight -> Start CUDA Debugging from the main menu
  3. Any other GPUs installed on the machine?
  4. Does your project configuration have debug info on (-G)?
  5. Where are you setting your breakpoints? Nsight only supports GPU/kernel debugging, no mix mode with CPU
  6. Officially, Nsight 2.2 does not support the 640 GT, however "it should work"

Thanks

  1. yes I meant visual studio 2008
  2. yes
  3. no other GPU’s
  4. I clicked the project with right mouse button and choose properties than I go to Active(debug) -> debugging -> Command Arguments and put there -G is that right?
  5. my break point is inside the kernel

what do you think?

thanks

I’ll need to get ahold of a GT 640, but I’ll look into the issue.

I got the same issue. Have 2 GPUs installed. Does this matter?

I haven’t been able to reproduce the issue.

samurairen, what is your configuration?