NSight 5.5 skips all the breakpoints in visual studio 2015

Hi guys,

I’m debugging a large visual studio solution. For some reason though I set breakpoints the CUDA debugger skips them. I’ve checked if the -g option is on in the ProjectProperties > CUDA C/C++ etc but still doesn’t work. Also the .ptx generation is enabled as well.

Is there anything you can suggest?

Hi,

Sorry for the problem you met.

Can you tell which debugger(legacy or next-gen) are you using ?

Also please tell the GPU you want to debug on.

Thanks !

Of course,

Debugger is “legacy”.
The GPU is GTX 1070.

I’ve just tried following this guide : http://docs.nvidia.com/nsight-visual-studio-edition/Nsight_Visual_Studio_Edition_User_Guide.htm#Attach_CUDA_to_Process.htm%3FTocPath%3DCUDA%20Debugger|Build%20and%20Run|_____3

But still doesn’t work, once I attach the process something runs but I can’t step through the code lines. They says this should be equivalent to run the Cuda debugger, but to me still doesn’t work.

Help would be highly appreciated.

Some more info about my problem are available here:

https://stackoverflow.com/questions/49279735/cuda-nsight-5-5-and-visual-studio-2015-skipping-all-the-break-points

Hi, l.gagliano

I checked the stackoverflow, in that case the breakpoint is in CPU code not GPU code, right ?

As far as I know, legacy debug do not support CPU code debugging.

Is this also your case, settting the breakpoint in CPU code ?

Hi veraj,

There was an issue with some of the flags of the nvcc compiler (-gencode) they weren’t matching the architecture of my gpu, whose capabilities are 6.1.

About where I set the breakpoints, one was in the CPU code, while the other is in the GPU code, but I got confused at the beginning, I realized later.

It seems to be working now, at least with the examples.

Thank you

Hi, l.gagliano

It’s great it works for you now.

If you have any other question, feel free to ask.

Thanks !