Cannot execute OptiX 8.0.0 Samples because of sutil_7_sdk

I recently installed OptiX 8.0.0 and built its samples by using CMake, but it does not works, and it always shows this error message.

스크린샷 2024-04-24 035920

I used Windows 11, VS 2022, CMake 3.29.1, CUDA 12.4, Driver version 551 and OptiX 8.0.0. What is the matter?

Could you please translate the error message into English?
(It’s not possible to paste that into a translator because you attached text as an image.)

What is is your OS’ local language setting ?

In CMake did you configure and generate the solution for Visual Studio 17 2022 and selected x64 as platform? (x86 32 bit won’t work!)

There might be an issue with the language settings in the build system, not handling unicode correctly maybe.

I cannot tell if this is the same as

Yes, I already used VS 2022 and x64.

I changed local language and VS studio’s language to English and tried again, and it returned 'LNK1104: cannot open file ‘…\lib\Debug\sutil_7_sdk.lib’.

Actually, the directory does not have any character which violates Unicode anyway…

OK, that’s sounds manageable.

Did you use the OptiX SDK 8.0.0\SDK folder with the the top-most CMakeLists.txt as source directory?
(The individual example’s CMakeLists.txt won’t work standalone. )

Did you select a local build target folder inside the CMake GUI? E.g. OptiX SDK 8.0.0\SDK\build

Did you rebuild the whole solution?

Does it work for the Release x64 target?
(Note that OptiX builds Debug targets with debug device info inside the OptiX device code and the examples will run super slow then. )

Are there any other errors inside the MSVS output window?
(I haven’t tried CUDA 12.4 yet. I have no issues building the OptiX SDK 8.0.0 examples with CUDA 12.2 though.
In case there are errors from the NVCC compilation, increasing the MSBuild verbosity would show more info: )