Can't get 24 bit color depth

I have a 650 TI Boost with 3 monitors DFP-1 (DVI-D) 1920x1200, DFP-3 (HDMI) 1920x1200, and CRT-0 (VGA/DVI-I) 1024x76. I would like to run them at 24 bit color. No matter what I do, I get 16 bit color. Is this a hardware or driver limitation?

I’ve tried unplugging monitors and running single monitor and lower resolutions. No luck. This has been going on for a very long time. It is not specific to this kernel or driver version.

Any help would be greatly appreciated.


Fedora 21 64bit
4.0.5-200.fc21.x86_64 #1 SMP Mon Jun 8 16:25:02 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

01:00.0 VGA compatible controller: NVIDIA Corporation GK106 [GeForce GTX 650 Ti Boost] (rev a1)

driver packages


I’ve tried with and without xorg.conf no luck either way.

xwininfo -root

xwininfo: Window id: 0x136 (the root window) (has no name)

Absolute upper-left X: 0
Absolute upper-left Y: 0
Relative upper-left X: 0
Relative upper-left Y: 0
Width: 4864
Height: 1200
Depth: 16
Visual: 0x21
Visual Class: TrueColor
Border width: 0
Class: InputOutput
Colormap: 0x20 (installed)
Bit Gravity State: ForgetGravity
Window Gravity State: NorthWestGravity
Backing Store State: NotUseful
Save Under State: no
Map State: IsViewable
Override Redirect State: no
Corners: +0+0 -0+0 -0-0 +0-0
-geometry 4864x1200+0+0

When I try to use nvidia-settings to change the depth for x screen 0, it throws an error box:

Cannot Apply

The current settings cannot be completely applied due to one or more of the following reasons:
The location of an X screen has changed
The location type of an X screen has changed
The color depth of an X screen has changed
An X screen has been added or removed
Xinerama is being enabled or disabled

For all the requested settings to take effect,
you must save the configuration to the X config
file and restart the X server.

When I save the xorg.conf and reboot I get a GDM Oh no something has gone wrong!

The nvidia-settings generated xorg.conf:

nvidia-settings: X configuration file generated by nvidia-settings

nvidia-settings: version 352.21 (buildmeister@swio-display-x64-rhel04-13) Tue Jun 9 22:42:41 PDT 2015

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 0 0
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “0”

Section “Files”
FontPath “/usr/share/fonts/default/Type1”

Section “InputDevice”
# generated from default
Identifier “Mouse0”
Driver “mouse”
Option “Protocol” “auto”
Option “Device” “/dev/input/mice”
Option “Emulate3Buttons” “no”
Option “ZAxisMapping” “4 5”

Section “InputDevice”
# generated from default
Identifier “Keyboard0”
Driver “keyboard”

Section “Monitor”
# HorizSync source: edid, VertRefresh source: edid
Identifier “Monitor0”
VendorName “Unknown”
ModelName “HannStar Display Corp HZ281H”
HorizSync 30.0 - 85.0
VertRefresh 50.0 - 75.0
Option “DPMS”

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “GeForce GTX 650 Ti BOOST”

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24
Option “Stereo” “0”
Option “nvidiaXineramaInfoOrder” “DFP-3”
Option “metamodes” “DVI-D-0: nvidia-auto-select +1920+0, DVI-I-0: nvidia-auto-select +3840+0, HDMI-0: nvidia-auto-select +0+0”
Option “SLI” “Off”
Option “MultiGPU” “Off”
Option “BaseMosaic” “off”
SubSection “Display”
Depth 24

nvidia-bug-report.log.gz (143 KB)

Can you please run and attach the generated nvidia-bug-report.log.gz file to your post? Also, please check /var/log/Xorg.0.log and check which xorg.conf file it’s using. The X server’s search path is a little strange so it might be picking up one from a strange location (e.g. /root/xorg.conf).

nvidia-bug-report.log.gz attached.

Using config file: "/etc/X11/xorg.conf

Thank you for your assistance!
nvidia-bug-report.log.gz (143 KB)

Try deleting

Section "Files"
FontPath "/usr/share/fonts/default/Type1"

as it overrides the module path set in /etc/X11/xorg.conf.d/99-nvidia.conf

Thanks leigh123linux.

Removing the Files section fixed the GDM issue, but it still comes up in 16 bit color :(

A fresh bug-report log is attached after the successful boot with the new xorg.conf.

nvidia-bug-report.log.gz (142 KB)


/etc/X11/xorg.conf.d/10-libvnc.conf had a depth setting in it :(

Thanks for taking time to look at this!

Oh yeah, that’ll do it! :)

Sorry I didn’t manage to get back to this before you solved it yourself.