Can't install drivers on ubuntu 18.04 LTS

motd-news.service is a disabled or a static unit, not starting it.
Setting up libstdc++6:amd64 (8.3.0-26ubuntu1~18.04) …
(Reading database … 563501 files and directories currently installed.)
Preparing to unpack …/nvidia-430_430.06.03-0ubuntu1_amd64.deb …
Unpacking nvidia-430 (430.06.03-0ubuntu1) …
dpkg: error processing archive /var/cuda-repo-10-2-local-10.2.17-430.06.03/./nvidia-430_430.06.03-0ubuntu1_amd64.deb (–unpack):
trying to overwrite ‘/sbin/create-uvm-dev-node’, which is also in package nvidia-kernel-common-390 390.116-0ubuntu0.18.04.1
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cuda-repo-10-2-local-10.2.17-430.06.03/./nvidia-430_430.06.03-0ubuntu1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Anyone have any suggestions?

Looks like you’re trying to install cuda including the bundled driver while already having a driver installed. If so, try this:

  • download the cuda .deb
  • add the repo to your system (first three steps from install instructions on download page)
  • don’t install cuda
  • instead, run sudo apt install cuda-toolkit-10-2

Ok, I followed those instructions and now I have a broken package:
a$ sudo apt install cuda-toolkit-10-2
Reading package lists… Done
Building dependency tree
Reading state information… Done
cuda-toolkit-10-2 is already the newest version (10.2.89-1).
cuda-toolkit-10-2 set to manually installed.
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
cuda-libraries-dev-10-2 : Depends: libcublas-dev (>= 10.2.2.89) but it is not going to be installed
cuda-samples-10-2 : Depends: libcublas-dev (>= 10.2.2.89) but it is not going to be installed
cuda-visual-tools-10-2 : Depends: libcublas-dev (>= 10.2.2.89) but it is not going to be installed
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).
sudo apt --fix-broken install Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... Done The following additional packages will be installed: libcublas-dev The following NEW packages will be installed: libcublas-dev 0 upgraded, 1 newly installed, 0 to remove and 33 not upgraded. 55 not fully installed or removed. Need to get 0 B/42.3 MB of archives. After this operation, 114 MB of additional disk space will be used. Do you want to continue? [Y/n] Y Get:1 file:/var/cuda-repo-10-2-local-10.2.89-440.33.01 libcublas-dev 10.2.2.89-1 [42.3 MB] (Reading database ... 547657 files and directories currently installed.) Preparing to unpack .../libcublas-dev_10.2.2.89-1_amd64.deb ... Unpacking libcublas-dev (10.2.2.89-1) ... dpkg: error processing archive /var/cuda-repo-10-2-local-10.2.89-440.33.01/./libcublas-dev_10.2.2.89-1_amd64.deb (--unpack): trying to overwrite '/usr/include/nvblas.h', which is also in package nvidia-cuda-dev 9.1.85-3ubuntu1 dpkg-deb: error: paste subprocess was killed by signal (Broken pipe) Errors were encountered while processing: /var/cuda-repo-10-2-local-10.2.89-440.33.01/./libcublas-dev_10.2.2.89-1_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1) jrucker@jrucker-desk:~/jim/cuda sudo apt purge libcublas-dev
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package ‘libcublas-dev’ is not installed, so not removed
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
cuda-libraries-dev-10-2 : Depends: libcublas-dev (>= 10.2.2.89) but it is not going to be installed
cuda-samples-10-2 : Depends: libcublas-dev (>= 10.2.2.89) but it is not going to be installed
cuda-visual-tools-10-2 : Depends: libcublas-dev (>= 10.2.2.89) but it is not going to be installed
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).

trying to overwrite '/usr/include/nvblas.h', which is also in package nvidia-cuda-dev 9.1.85-3ubuntu1 dpkg-deb

Looks like you already had cuda-9.1 installed. Please remove all previously installed cuda packages. Often needs some iterations:
https://forums.developer.nvidia.com/t/problems-installing-cuda-10-1-on-my-computer/77110/29