CentOS 8 Stream display stuck on 1024x768 after CUDA install

OS: CentOS 8 Stream 64
Nvidia Card: Geforce GTX Titan Black 6GB (GK110B)

I downloaded and ran the following script.

$ wget https://developer.download.nvidia.com/compute/cuda/11.2.1/local_installers/cuda-repo-rhel8-11-2-local-11.2.1_460.32.03-1.x86_64.rpm

$ sudo rpm -i cuda-repo-rhel8-11-2-local-11.2.1_460.32.03-1.x86_64.rpm

$ sudo dnf clean all

$ sudo dnf -y module install nvidia-driver:latest-dkms

$ sudo dnf -y install cuda

After installing the CUDA development pack, the display appears to not be fully functional. When running the following command before and after the install, it would appear that I have a valid device:

$ lspci | grep -i invida
01:00.0 VGA compatible controller: NVIDIA Corporation GK110B [Geforce GTX TITAN Black] (rev a1)

I run the following command, wait for completion, and restart machine

$ sudo yum install cuda

To bring system back as before I run the following and then restart system:

$ sudo dnf remove nvidia-driver

Among other things, before uninstalling the driver, when running ‘nvcc’, I get “Command not found”. Please advise. Is CentOS 8 not supported? EOL has been announced for CentOS 8, so using CentOS 8 Stream due to support.

Using the following guide for reference:

https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html