CUDA driver version is insufficient for CUDA runtime version on CentOS 7.5

I’m trying to do the runfile installation for cuda_10.0.130_410.48_linux but keep getting this result:

./deviceQuery Starting...

 CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 35
-> CUDA driver version is insufficient for CUDA runtime version
Result = FAIL

Before installing, I removed previous installation attempts with:

sudo yum remove 'cuda-*'

Other info that may be relevant:

Thu Sep 27 10:31:36 2018
| NVIDIA-SMI 410.48                 Driver Version: 410.48                    |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|   0  Quadro P6000        Off  | 00000000:03:00.0 Off |                  Off |
| 19%   55C    P0    63W / 250W |      0MiB / 24449MiB |      2%      Default |

| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|  No running processes found                                                 |
lspci -v | grep -i nvidia
03:00.0 VGA compatible controller: NVIDIA Corporation GP102GL [Quadro P6000] (rev a1) (prog-if 00 [VGA controller])
	Subsystem: NVIDIA Corporation Device 11a0
	Kernel driver in use: nvidia
	Kernel modules: nouveau, nvidia_drm, nvidia
uname -m && cat /etc/*release
CentOS Linux release 7.5.1804 (Core)
NAME="CentOS Linux"
VERSION="7 (Core)"
ID_LIKE="rhel fedora"
PRETTY_NAME="CentOS Linux 7 (Core)"


CentOS Linux release 7.5.1804 (Core)
CentOS Linux release 7.5.1804 (Core)
gcc --version
gcc (Homebrew gcc 5.5.0_1) 5.5.0
uname -r
lsmod | grep nouveau

prints nothing

I’ve also tried the rpm installation but with the same result. Thanks for any help.

No one can help? I’m at a total loss. I don’t understand why it’s saying the CUDA driver is insufficient for CUDA runtime version… I have CUDA 10.0 which is supposed to be compatible with driver v410.48.

one possibility is that you have a previous package manager driver install that was not properly cleaned out.

You could try starting out with a clean load of the OS, and follow the instructions in the linux install guide carefully.