Chmod: cannot access 'ngc': No such file or directory

@morganh saw that there was a recent issue with NGC in TAO that the team has fixed in TAO. I ran into that problem. I’ve also run into what could be a related problem which results into that same error message.

Am trying to build the TensorRT OSS for a new A2 server

and am getting the following error:
chmod: cannot access ‘ngc’: No such file or directory

Download TensorRT OSS

git clone -b master TensorRT
cd TensorRT
git submodule update --init --recursive


Generate the TensorRT-OSS build container.
The TensorRT-OSS build container can be generated using the supplied Dockerfiles and build script. The build container is configured for building TensorRT OSS out-of-the-box.
Example: Ubuntu 20.04 on x86-64 with cuda-11.6.2 (default)

sudo ./docker/ --file docker/ubuntu-20.04.Dockerfile --tag tensorrt-ubuntu20.04-cuda11.6

then results in

 inflating: ngc-cli/boto3/data/cloudformation/2010-05-15/resources-1.json
   creating: ngc-cli/boto3/data/dynamodb/
   creating: ngc-cli/boto3/data/dynamodb/2012-08-10/
  inflating: ngc-cli/boto3/data/dynamodb/2012-08-10/resources-1.json
   creating: ngc-cli/boto3/data/sqs/
   creating: ngc-cli/boto3/data/sqs/2012-11-05/
  inflating: ngc-cli/boto3/data/sqs/2012-11-05/resources-1.json
   creating: ngc-cli/boto3/data/s3/
   creating: ngc-cli/boto3/data/s3/2006-03-01/
  inflating: ngc-cli/boto3/data/s3/2006-03-01/resources-1.json
  inflating: ngc-cli/
   creating: ngc-cli/frozenlist/
  inflating: ngc-cli/frozenlist/
 extracting: ngc-cli.md5
chmod: cannot access 'ngc': No such file or directory
The command '/bin/bash -c cd /usr/local/bin && wget && unzip && chmod u+x ngc && rm ngc.md5 && echo "no-apikey\nascii\n" | ngc config set' returned a non-zero code: 1

Please create a topic in Tensorrt forum. Thanks.

This looks like TensorRT related. We are moving this post to the TensorRT forum to get better help.
Thank you.

Ok Great. Thank you.

Hi @brandt33,

Sorry, as you are facing an issue in setting up TensorRT OSS, we recommend you to please create a git issue on Issues · NVIDIA/TensorRT · GitHub to get better help.

Thank you.