"cicc" compilation error


When compiling tensorflow using bazel inside docker container, I see this error -

nvcc error : ‘cicc’ died due to signal 9 (Kill signal)
ERROR: /usr/local/tensorflow/tensorflow/core/kernels/BUILD:903:1: output ‘tensorflow/core/kernels/_objs/tile_ops_gpu/tensorflow/core/kernels/tile_functor_gpu.cu.pic.o’ was not created
ERROR: /usr/local/tensorflow/tensorflow/core/kernels/BUILD:903:1: not all outputs were created or valid
Target //tensorflow:libtensorflow_cc.so failed to build
Use --verbose_failures to see the command lines of failed build steps.
INFO: Elapsed time: 10740.668s, Critical Path: 1192.85s
INFO: 4356 processes: 4356 local.
FAILED: Build did NOT complete successfully

I ran the following build command -
…/bazel/bin/bazel build --config=opt --config=cuda --verbose_failures //tensorflow:libtensorflow_cc.so --per_file_copt=//tensorflow/.*.cu.cc@-D_FORCE_INLINES --local_resources 2048,.5,1.0

I even tried adding the following cxx_flags: (-D_FORCE_INLINES, D__STRICT_ANSI__, and -D_MWAITXINTRIN_H_INCLUDED to /third_party/gpus/CROSSTOOL, yet continue to get the same error.

Any solutions to what I can try?

System specs -
(Building inside HeliOS 7 docker container)
With Tensorflow 1.12, Bazel 0.15, CuDNN 7.4.1 and CUDA Toolkit 10.0
Gcc version 4.8.5


If you wish to file a bug report, do so by following the process here: