"CONFIG_USB_SERIAL_PL2303 is not set"

I am new to the Orin and have been having a lot of trouble resolving an issue of connecting a Cyglidar D1 via UART to USB adapter to my Jetson Orin Nano 8GB Developer Kit with Jetpack 6.0 and release 36.3. It is not creating a ttyUSB0 or any new tty when I plug in the Cyglidar (which I know is on because the light works). But when I type lsusb it outputs “Bus 001 Device 008: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port / Mobile Action MA-8910P” but when I check the config.gz file for PL2303 with the line “sudo zcat /proc/config.gz | grep PL2303” it outputs: “# CONFIG_USB_SERIAL_PL2303 is not set”

I read in a separate post that you need to rebuild the kernel to include pl2303. As a beginner, I was lost in the instructions and was wondering if someone could give a more detailed process of modifying the kernel and rebuilding it.

Hi chmalinc,

It seems Orin Nano has detected PL2303 on USB port.

Is there any /dev/ttyUSB* showed after you plug this “USB to UART”(TTL) cable?

To re-build the kernel for JP6.0GA(R36.3), you can refer to Kernel Customization — NVIDIA Jetson Linux Developer Guide 1 documentation for details.

Thank you for the quick response KevinFFF.

No, three is no /dev/ttyUSB* after I plug in the USB cable.

I tried to follow those instructions previously, but after attempting the line “./source_sync.sh -k -t ” while in /Linux_for_Tegra/source it resulted with bash: ./source_sync.sh: No such file or directory.

I then tried manual download and expand the kernel sources which worked.

I then did Building the Jetson Linux Kernel, but when I got to step 3. I used the these instructions to get my toolchain-path then typed “make -C kernel” and it output this:

make: Entering directory ‘/home/mae-emrl3172/Downloads/Linux_for_Tegra/source/kernel’

Building kernel-jammy-src sources

make
ARCH=arm64
-C /home/mae-emrl3172/Downloads/Linux_for_Tegra/source/kernel/kernel-jammy-src
LOCALVERSION=-rt-tegra
defconfig
make[1]: Entering directory ‘/home/mae-emrl3172/Downloads/Linux_for_Tegra/source/kernel/kernel-jammy-src’
*** Default configuration is based on ‘defconfig’
/home/mae-emrl3172/l4t-gcc/aarch64–glibc–stable-2022.08-1/bin/aarch64-buildroot-linux-gnu-gcc: unknown compiler
scripts/Kconfig.include:44: Sorry, this compiler is not supported.
make[2]: *** [scripts/kconfig/Makefile:87: defconfig] Error 1
make[1]: *** [Makefile:630: defconfig] Error 2
make[1]: Leaving directory ‘/home/mae-emrl3172/Downloads/Linux_for_Tegra/source/kernel/kernel-jammy-src’
make: *** [Makefile:30: kernel] Error 2
make: Leaving directory ‘/home/mae-emrl3172/Downloads/Linux_for_Tegra/source/kernel’
mae-em

That is where I stopped because it said the compiler is not supported. Is there a step I missed?

Do you have source_sync.sh under <Linux_for_Tegra>/source/?

How did you setup for toolchain to build the kernel?
What’s the distribution and release of your host?

@KevinFFF

No, I don’t have source_sync.sh under <Linux_for_Tegra>/source/

I followed these instructions to set up toolchain.

I am using Jetpack 6.0 with Ubuntu 22.04

It’s not the expected result to me.

Please refer to the steps in To Flash the Jetson Developer Kit Operating Software to setup BSP package and you should have source_sync.sh under <Linux_for_Tegra>/source/.

@KevinFFF

I apologize for the miscommunication, should all of these steps be done on my host linux pc?

Yes, you should download the source → modify kernel config(in defconfig) → compile kernel image → update kernel image in BSP package → flash the board to apply the change.
All above steps should be done on host PC.