Connect Jetson Nano to a laptop camera via RTP


Yes, I run Linux on the laptop. I followed the steps on Jetson Nano FAQ and when I run:

$ ./test-launch “videotestsrc ! x264enc ! h264parse ! rtph264pay name=pay0 pt=96”

it outputs stream ready at rtsp://

Then on my Jetson:

$ gst-launch-1.0 uridecodebin uri=‘rtsp://<IP_HOST>:8554/test’ ! nvoverlaysink

I get:

Setting pipeline to PAUSED ...
Pipeline is live and does not need PREROLL ...
Progress: (open) Opening Stream
Progress: (connect) Connecting to rtsp://<IP_HOST>:8554/test
Progress: (open) Retrieving server options
Progress: (open) Retrieving media info
ERROR: from element /GstPipeline:pipeline0/GstURIDecodeBin:uridecodebin0/GstRTSPSrc:source: Unhandled error
Additional debug info:
gstrtspsrc.c(6161): gst_rtspsrc_send (): /GstPipeline:pipeline0/GstURIDecodeBin:uridecodebin0/GstRTSPSrc:source:
Service Unavailable (503)
ERROR: pipeline doesn't want to preroll.
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...

What am I doing wrong?

Note: IP_HOST is my laptop IP.