Could not find any implementation for node {foreignNode[onnx::scatterND 345 ... Transpose 19675]}

Description

I have converted my pytorch model to onnx, and onnx.checker.check_model() was used to check the onnx model, there is no error.

But when i convert the onnx to trt with Python API or trtexec, i got the same error – “could not find any implementation for node {foreignNode[onnx::scatterND 345 … Transpose 19675]}.”

Environment

TensorRT Version: 8.6.1.6
GPU Type: Jetson
Nvidia Driver Version:
CUDA Version: 12.0
CUDNN Version: 8.6
Operating System + Version: linux ubuntu20.04
Python Version (if applicable): 3.8
TensorFlow Version (if applicable):
PyTorch Version (if applicable): 1.11
Baremetal or Container (if container which image + tag):

Relevant Files

My onnx model is here:
Uploading: small.zip…

Steps To Reproduce

my command is here:
trtexec --onnx=small.onnx --saveEngine==small.trt --fp16 --verbose

the error is:

Hi @846443037 ,
This is a known issue by CUDA bug and fixed in the latest SW.
Thanks

Thanks for your reply !

The work run in Xvaier NX, NX was installed with JetPack5.1.3 by default, and cuda supports up to 11.4. I installed cuda12.0 and 12.4 manually. The same error occurred under both versions of cuda.

Yes, with the best of my knowledge, the bug has been addressed to be resolved in latest SW.
however if the issue still persist, i would recommend you to reach out to JEtson Xavier Forum.

Thanks

OK, thank you !

Have you solved this problem?