CUDA 4.0 problem

Hi!
My notebook GPU works well with CUDA 4.0 RC2, but it can’t works with the new released CUDA 4.0 ! For the example of dviceQuery:

[deviceQuery.exe] starting…
D:\CUDA\NVIDIA GPU Computing SDK 4.0\C\bin\win32\Release\deviceQuery.exe Starting…

CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 3
-> initialization error
[deviceQuery.exe] test results…
FAILED

Press ENTER to exit…

  Does anyone know why?

Same problem here. Using a GTX 460M (driver version 270.61), Windows 7 x64.

Everything was running fine with CUDA Toolkit 4.0 RC2 and VS2008. After installing CUDA Toolkit 4.0 final and rebuilding the project, a simple program like:

int main(int argc, char* argv[])

{

    int deviceCount;

    cudaError_t err = cudaGetDeviceCount(&deviceCount);

}

fails with err == cudaErrorInitializationError

All GPU Computing SDK CUDA samples trigger the same issue since final version (4.0 RC2 samples were OK). DirectCompute and OpenCL samples are not affected by the issue.

Vow! Thas cool. How come they did not test something so basic? Thank god, I have not updated to CUDA 4.0 for my demos today…

the same for me: http://forums.nvidia.com/index.php?showtopic=201375

Also on a laptop card (QUADRO FX 1800M)

Maybe a problem with the notebook driver?

ARF

  • pium

Same problem here on Linux/Gentoo 64bit.

Updating nvidia drivers from 270.41.06 to 270.41.19 solved the problem.

Ingo

Same problem here with my notebook G310M card. Any ideas? I’m using the 270.61 drivers.

What happens if you run deviceQueryDrv? If that doesn’t work either, then it’s a driver issue; if it does, then it’s a runtime issue (which is somewhat easier to solve).

Also, there are new beta drivers out (275-series)…have you tried them at all?

The deviceQueryDrv is Ok. It seems that any example using runtime api can’t run correctly .

You said it’s easier to solve, how?

Thank you!

Exactly the same problem I have on a mbp with 8600m GT…

Waiting for ideas…

Ps: Here (http://www.itpub.net/thread-1440873-1-1.html# in chinese ^^) they suggest to use 270.4x driver…

I am going to try tomorrow, if someone does it before, let us know

Tried devdriver 270.28 without success…

I am also experiencing the same problem on an Asus g73w with GTX460M.
Hoping for a revised driver.

Has somebody tried the beta driver?

Jack.T, I have exactly the same problem with Asus N71Jv (optimus GT325M) :wallbash:

deviceQueryDrv passes with GPU Computing SDK 4.0 final and driver version 270.61.

All GPU Computing SDK 4.0 CUDA samples now DO run properly with beta driver 275.27 on my GTX 460M (issue disappeared with this driver version).

Here too, 275.27-notebook-win7-winvista-64bit-international-beta.exe on 8600m GT

Everything works ^^

Works for me too, thank you! :)

I also had a problem with CUDA 4.0 (+driver 270.51), but now the problem is resolved.
New driver:270.81 is released, and after installing this, everything is working fine.
You can download it from official CUDA download page.

Yes, with beta 275.27 everything works fine!
Thanks

I have tried 270.51 beta, also with 267.76. Both are unsuccessful.

Wow,I didn’t find drvier v275.27 corresponding with my NV card . My system is 32-bit.