CUDA 5.0 - insufficient driver version

My GPU is GeForce 840M with 416.81 driver version, latest CUDA Toolkit version is 5.0 and I have it installed. Now I’m trying to run this example code from some book and I’m getting an error on Visual Studio console (after successful compilation):

CUDA driver version is insufficient for CUDA runtime version in [ location] at line 11

#include <stdio.h> 
#include "book.h"

__global__ void add( int a, int b, int *c ) {
    *c = a + b; 

int main( void ) {
    int c;
    int *dev_c;
    HANDLE_ERROR( cudaMalloc( (void**)&dev_c, sizeof(int) ) );

    add<<<1,1>>>( 2, 7, dev_c );

    HANDLE_ERROR( cudaMemcpy( &c, 
                              cudaMemcpyDeviceToHost ) );
    printf( "2 + 7 = %d\n", c );
    cudaFree( dev_c );
    return 0; 

Does anyone know where the problem is? Maybe the GPU driver version? For now, I am not very familiar with this environment, although probably everything is not well configured to be able to do something and learn something. Please help.

EDIT: Problem solved. I don’t know why this has been fixed, but now it works after updating the GPU driver and restarting the computer.