cuda 9.2.88 on Fedora 28?

Hi,

do you know if the current cuda release will run on Fedora 28?

The docs say Fedora 27 is supported, with gcc 7.3.1. Fedora 28 has 8.1.1.

Alternatively, would anyone happen to know when Fedora 28 will be supported?

Thanks a lot,
Sigrid

I’d love to know this as well. Did you try it?

Just adding another voice to this… would be great to get some official support for Fedora 28. I couldn’t get the runfile for 27 to work out of the box, but didn’t try to figure out why yet.

Here is a question for nVidia… how many of these actually work?

Table 1. Native Linux Distribution Support in CUDA 9.2
Distribution Kernel* GCC GLIBC ICC PGI XLC CLANG
x86_64
RHEL 7.x 3.10.0 4.8.5 2.17 17.0 18.x NO 5.0.0
RHEL 6.x 2.6.32 4.4.7 2.12
CentOS 7.x 3.10.0 4.8.5 2.17
CentOS 6.x 2.6.32 4.4.7 2.12
Fedora 27 4.15.x 7.3.1 2.26
OpenSUSE Leap 42.3 4.4.120 4.8.5 2.22
SLES 12 SP3 4.4.120 4.8.5 2.22
Ubuntu 17.10 4.13 7.2.0 2.26
Ubuntu 16.04.4(**) 4.4.0 5.4.0 2.23

From trial and error I can tell you OpenSUSE no longer distributes this kernel, Fedora 28 is now the standard shipping, Ubuntu 17.10 is no longer available for distribution… Once I was able to install on CentOS 7.xx I gave up my research.

NVidia needs to install some automated testing or hire someone to make sure this goes well for developers without brain surgery to get the nouveau driver uninstalled or find the correct distribution on the various linux releases.

Yet another person eagerly hoping for Fedora 28 support

Fedora 27 w/ official kernel update to 4.17.9-100 fails to run cuda_9.2.148_396.37_linux.run as opposed to what https://developer.nvidia.com/cuda-downloads?target_os=Linux&target_arch=x86_64&target_distro=Fedora&target_version=27&target_type=runfilelocal suggests.

The officially supported (read: tested) kernel for Fedora 27 is listed in the linux install guide:

https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html

Fedora 27 is the only way to go… but it’s about a year old. It’s hard to believe that nVidia doesn’t keep up to date with major linux releases like they do for Windows 10 and MacOS. A bit of automated testing and communication with the respective linux release teams goes a long way to avoid issues like this.

Nvidia is terrible at supporting OS and tools.

why do we wait over a year and they still don’t offer current support for supposedly supported OS like Fedora

This happens year after year on every OS and toolset. They make billions and cant even hire a single person to keep things up to date.

for those that find this, it works for me.

PLEASE NVIDIA SORT YOUR STUFF OUT. ITS EMBARRASSING (FOR YEARS YOU DONT KEEP UP TO DATE)

https://skysymbol.noblogs.org/post/2018/05/26/how-to-install-cuda-9-0-cudnn-tensorflow-pytorch-on-fedora-28/

Install GCC 5

Cuda 9.0 requires a GCC version inforior <= 6. We install GCC 5 from mageia packages as Fedora does not provide old packages for GCC.

wget https://rpmfind.net/linux/mageia/distrib/6/x86_64/media/core/updates/gcc-c++-5.5.0-1.mga6.x86_64.rpm https://rpmfind.net/linux/mageia/distrib/6/x86_64/media/core/updates/gcc-5.5.0-1.mga6.x86_64.rpm https://rpmfind.net/linux/mageia/distrib/6/x86_64/media/core/updates/libstdc++-static-devel-5.5.0-1.mga6.x86_64.rpm https://rpmfind.net/linux/mageia/distrib/6/x86_64/media/core/updates/libstdc++-devel-5.5.0-1.mga6.x86_64.rpm

rpm -ivh --force --nodeps *.rpm

Fedora 27 comes with kernel 4.13 and updates itsself to 4.17. How to get to 4.15 for which the Cuda runfile is working?

I have successfully installed CUDA 9.2.148 on Fedora27 with the initial kernel:

uname -a

Linux cluster2 4.13.9-300.fc27.x86_64 #1 SMP Mon Oct 23 13:41:58 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

I’m not sure what the problem is with the 4.17 kernel - I believe it should be possible to use with that kernel, and the previous message gives no indication of what the problem is.

Yes, I confirm that 4.13 is working fine. However, the problem w/ 4.17 is a blank screen after reboot to graphical model (that is following the installation guide very closely).

Just for the record, after trying several things I do not see a way to get the following combination to work:

  • Fedora 28 with kernel 4.17 (anyway I would want a solution where I can just normally upgrade kernels, so staying with 4.13 is not an option)
  • Lenovo P51, with “discrete graphics” selected in BIOS
  • M2200 GPU

For that GPU type, the most recent driver I am able to install is 396.18 (which is beta). If I install that driver standalone , as per https://www.if-not-true-then-false.com/2015/fedora-nvidia-guide/, it works.

However, I can make neither cuda 9.1 or cuda 9.2 work with that driver (nvidia-smi gives driver/client mismatch). This was from dnf install. Theoretically, for that driver, 9.1 should be in the compatible range so that should have worked.
For both these combinations, installations did not fail but any graphical programs (firefox) were totally unusable and had to be killed.

I also tried the 9.2 runfile install that includes a driver, after installing gcc and the other libraries mentioned by LukeCuda above (version 7.3.1). This never booted into graphical mode.

Officially, Fedora 28 is not listed as supported.

For Fedora 28 or Fedora 27 with 4.17 kernel, I would recommend using the 396.45 (or later) driver:

http://www.nvidia.com/download/driverResults.aspx/136233/en-us

download that runfile installer, be sure to remove nouveau from your system first (verify that lsmod |grep nouv returns nothing), then run that runfile installer.

If you intend to use a graphical desktop driven from the NVIDIA GPU, be sure to answer yes when prompted to install OpenGL libraries. Note that if you are doing this on an optimus laptop, this may not be the correct approach. A different method may be needed for optimus laptop. It will likely vary by laptop type and design, as well as possibly what displays are connected.

Then verify correct GUI operation, and also that nvidia-smi returns a sane result.

At that point, use the CUDA 9.x runfile CUDA toolkit installer, and select “no” when prompted to install a driver.

It should be possible to use this method with DKMS if desired, so that the driver install will survive subsequent kernel updates. However I’ve not listed out all the DKMS install/usage steps.

For general runfile install method instructions, refer to the linux install guide:

https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html

I’ve not covered every step here. For example the post install instructions in section 7 also need to be performed.

Hi, thanks!

Unfortunately, that driver does not list my GPU among the supported products (M2200)…

If it were me, I would try it anyway. I think it should work fine on that GPU.

I don’t have your laptop, and I can’t provide any guarantees. If you’re not comfortable with trying it, don’t proceed with these directions.

OK! May I ask - as I’ve re-installed fedora 5 times today, trying different things - if my current state is that I’m already running an older nvidia driver (so, not nouveau anymore) - can I just download that driver, go to runlevel 3, and install the new one, or how should I proceed?
Thanks!

If you’ve explicitly removed nouveau already, it should be gone and not come back.

If your most recent driver install was via runfile installer method (and it is working correctly), then it should be OK just to go to runlevel 3, and then launch the new runfile installer (as root). I do that all the time.

If you have previously used the package manager method for driver install, then the above statements don’t apply. In that case you need to clean out the old install entirely (instructions are in the linux install guide) and start over from square 1, including possible nouveau removal steps.

My current install was from

NVIDIA-Linux-x86_64-396.18.run

following all the steps in the popular

https://www.if-not-true-then-false.com/2015/fedora-nvidia-guide/

(so, blacklisting nouveau, generating ramdisk, etc.)

Then I think I should be ready to go!