cuda compiler error

Hi Cuda Experts,

I just trying to compiler the sample projects included in the SDK, but never success. I always have a internal compiler error, below are the logs an details:

  • Operating System: Win 7 64bit home premium
  • Synopsis description of the problem: Cannot compile any of the cuda code
  • CUDA toolkit release version: cudatoolkit_4.1.28_win_64
  • SDK release version: gpucomputingsdk_4.1.28_win_64
  • Device Driver: devdriver_4.1_winvista-win7_64_286.16_notebook
  • Compiler for CPU host code: Microsoft Visual C++ 2010 Express
  • System description including: CPU: Core i7-267QM, CPU speed: 2.20GHz, RAM: 8GB, system type: Win7 64bit, video card: GT 540M

Build log:
1>------ Build started: Project: cutil, Configuration: Debug Win32 ------
1> stopwatch_win.cpp
1> stopwatch.cpp
1> cutil.cpp
1> cmd_arg_reader.cpp
1> bank_checker.cpp
1> Generating Code…
1> Creating library C:\ProgramData\NVIDIA Corporation\NVIDIA GPU Computing SDK 4.1\C\common\lib\Win32\cutil32D.lib and object C:\ProgramData\NVIDIA Corporation\NVIDIA GPU Computing SDK 4.1\C\common\lib\Win32\cutil32D.exp
1> Creating library C:\ProgramData\NVIDIA Corporation\NVIDIA GPU Computing SDK 4.1\C\common\lib\Win32\cutil32D.lib and object C:\ProgramData\NVIDIA Corporation\NVIDIA GPU Computing SDK 4.1\C\common\lib\Win32\cutil32D.exp
1> cutil_vs2010.vcxproj -> C:\ProgramData\NVIDIA Corporation\NVIDIA GPU Computing SDK 4.1\C\common\lib\Win32\cutil32D.dll
1> A subdirectory or file …\bin\win32\Debug already exists.
1> 1 file(s) copied.
2>------ Build started: Project: clock, Configuration: Debug Win32 ------
2> Compiling CUDA source file clock.cu…
2>
2> C:\ProgramData\NVIDIA Corporation\NVIDIA GPU Computing SDK 4.1\C\src\clock>“C:\Program Files (x86)\NVIDIA GPU Computing Toolkit\CUDA\v4.1\bin\nvcc.exe” -gencode=arch=compute_10,code=“sm_10,compute_10” -gencode=arch=compute_20,code=“sm_20,compute_20” --use-local-env --cl-version 2010 -ccbin “c:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin” -I"./" -I"…/…/common/inc" -I"…/…/…/shared/inc" -I"C:\Program Files (x86)\NVIDIA GPU Computing Toolkit\CUDA\v4.1\include" -G0 --keep-dir “Debug” -maxrregcount=0 --machine 32 --compile -g -Xcompiler “/EHsc /nologo /Od /Zi /MTd " -o “Win32/Debug/clock.cu.obj” “C:\ProgramData\NVIDIA Corporation\NVIDIA GPU Computing SDK 4.1\C\src\clock\clock.cu”
2>CUDACOMPILE : Internal error : assertion failed at: “D:/Bld/rel/gpgpu/toolkit/r4.1/compiler/edg/EDG_4.3/src/host_envir.c”, line 5353
2>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\BuildCustomizations\CUDA 4.1.targets(361,9): error MSB3721: The command ““C:\Program Files (x86)\NVIDIA GPU Computing Toolkit\CUDA\v4.1\bin\nvcc.exe” -gencode=arch=compute_10,code=“sm_10,compute_10” -gencode=arch=compute_20,code=“sm_20,compute_20” --use-local-env --cl-version 2010 -ccbin “c:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin” -I”./” -I"…/…/common/inc" -I"…/…/…/shared/inc" -I"C:\Program Files (x86)\NVIDIA GPU Computing Toolkit\CUDA\v4.1\include" -G0 --keep-dir “Debug” -maxrregcount=0 --machine 32 --compile -g -Xcompiler “/EHsc /nologo /Od /Zi /MTd " -o “Win32/Debug/clock.cu.obj” “C:\ProgramData\NVIDIA Corporation\NVIDIA GPU Computing SDK 4.1\C\src\clock\clock.cu”” exited with code 3.
========== Build: 1 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

Please help and see if I have anything missing to start my first Cuda program.

Thank you in advance!

James

Sorry for the inconvenience. I checked with our compiler team and they think this is an instance of a known issue, where “CUDAFE/CUDAFE++ in 4.1 cannot handle some system locale settings”. To work around this for now, they suggest to “try other system locale settings. The system locale setting is found at Control Panel -> Clock, Language, and Region -> Region and Language -> Administrative.”

Thanks, it seems working now, at least I can compile.

FYI, my locale setting was “Chinese Traditional (HKSAR)”.