CUDA *Display driver stopped working* on Windows 7 32/64 Display driver stopped working

Hi,

I have two machines, one running GeForce 8800 GTX, the other GTX 296.

I tried all four combinations of CUDA 2.2/2.3 for Windows 7 (driver, toolkit, and SDK) and Windows 7 Professional 32bit/64bit, but I keep getting the same crash message “Display driver stopped working but has recovered”, whenever I tried to execute my code using CUDA under Visual Studio 2008.

Has anyone seen anything like this? Appreciate any thoughts!

Thanks,

Chris
10-Nov-2009

Does a single kernel launch take more than two seconds to execute?

Yes, it takes a few seconds. However, this problem didn’t happen when I used the same GPU in a windows XP OS.

I’ve had this too. The reason was the watchdog timer - in XP it kicks in much later than in Win7.

http://www.microsoft.com/whdc/device/displ…dm_timeout.mspx

Note: I can’t find any reference to TdrDelay in my registry. Odd, I was sure I had it? Maybe some Windows Update ate it?

That solves the problem. Thanks!

I get the same problem as the poster when attempting to run seti, gpu+cpu, on Bonic 6.10.18 (i’m running “Lunatics_Win64v0.2_(SSE3+)_AP505r168_AKv8bx64_CudaV12” optimized applications). I’ve tried all drivers, now using the 195.55 beta drivers.

what keys did you change with regedit to resolve your problem?

system specs:
EVGA X58 Rev 1.0
Intel i7-920 @ 4.00GHz
2X BFG GTX 295 896MB
CORSAIR Dominator 6GB DDR3 800MHz CM3X2G1600C8D
Thermaltake ThoughPower 1200W
2X Seagate 1TB Drive in Raid 0
Danger Den Cube Case
MCR220 Radiator, MCP655

edit:
if i disable SLI, Bonic only detect two of the four GPU’s. if i enable SLI, Bonic detects all four but will trash work units (error), nvidia driver restarts, and eventually blue screen of death.
OS is Windows 7, 64 bit.

on the system below, i get: STOP Error 0x00000101!

STOP Error 0x00000101: CLOCK_WATCHDOG_TIMEOUT
STOP error 0x101 means that an expected clock interrupt on a secondary processor, in a multi-processor system, was not received within the allocated interval. STOP code 0x00000101 may also display “CLOCK_WATCHDOG_TIMEOUT” on the same STOP message.

Intel Skulltrail
dual E5320’s @ 2.8GHz
8GB FB mem
GTX280
Thermaltake ThoughPower 1200W
on H2O

I’ve disabled the watchdog timer in the bios, lets see if that fixes the problem.

Hi,

Actually I had none of those keys in my registry. I created a couple as below:

TdrDelay: I set to 600, TdrLevel: I tried 0 and 1 but don’t think is critical, TdrDdiDelay: to 600 as well.

Hope this helps, but obviously there should be better ways to configure these key values.

Maybe some one from Nvidia wants to say something about how they do this internally with Windows 7?

well the timer thing didn’t help, i’ve also tried the latest nvidia drivers 195.62. disabling the watch dog timer in bios didn’t help.

having the same problems - what is nvidia doin to fix this?

He Chris Liao,

I don’t knoww your problem, I think is something with the driver installed. but I would like ask you one thing, in your computer work Visual Studio 2008 64bit??

because on my laptop with Windows 7 64bit it dosen’t work (I have installed the exention for x64)

please let me know all your step to configure Visual Studio C++…

Thanks,

Michele

Same problem here :(… I tried also 191.07… no go. Badaboom (CUDA) continues crashing with the error you reported.

Help! i get the same on windows vista 64 when i run my opencl kernels, and i set the parameters to some value that makes it take a bit longer than usual
(it might well be more than 2 seconds, for the whole processing, not for a single kernel)

how can i avoid this error?

Note that you have to reboot after changing the TDR registry settings before the change takes effect.