CUDA driver version is insufficient for CUDA runtime version

Hi, I’m programming in python and wanted to use PyTorch on my home pc (Windows 10, GeForce 960) too. However I had some strange issues and currently I get again the error message in the title when trying to create a tensor on the GPU. I did the following:

  • I installed pytorch via pip with the command listed at The installation worked fine and I was able to use pytorch with my cpu and not with my gpu (this was expected, as I had not yet installed the CUDA toolkit).
  • I updated my GPU driver via the device manager (I wasn’t able to use pytorch with my gpu as expected)
  • I downloaded the CUDA toolkit (local installer for windows 10) from here and installed it. After a reboot, I was able to use pytorch with tensors on the GPU (as expected).
  • I recognized, that after some idle time, my screen went into energy save mode, but when waking it up again, one screen was showing strange artifacts he never showed before and I attributed that to the installation of the CUDA toolkit (this was obv. not expected)
  • I clicked on the “previous driver” button in the device manager to get back to normal. This worked out well, but I wasn’t able to use pytorch with the GPU anymore (this was probably expected).
  • I reinstalled the CUDA toolkit, but it somehow did not change the driver this time because the “previous driver”-button in the device manager is greyed out and I can’t use the gpu with pytorch (see error msg in the title). This was not expected.

So I have two questions:

  1. How can I get the CUDA driver back in place?
  2. How can I avoid the artifacts after the monitor went to sleep?