Problem when trying to install CUDA 10 on Windows

Hi, I ran into some troubles while installing CUDA 10 on Windows 10, GPU is GeForce MX130. I tried to install all packages, but installer failed for many components, including but not limited to: NPP runtime, CUPTI, Visual Studio Integration, Graphics Driver, and many more. It’s really puzzling.

What’s worse, after the failed installation, I found Nvidia Geforce Properties in my device manager with the following error code:

Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)

I need some help to complete the installation. Thanks!!

  1. Is this a laptop? If so, get the latest GPU driver for your laptop from the laptop manufacturer, and install it.

  2. If you then attempt to use a CUDA windows installer, deselect the option to install the bundled driver. Keep the driver you installed in step 1.

  3. When you choose a CUDA installer (e.g. CUDA 8, CUDA 9, CUDA 10, etc.) choose a version that is compatible with whatever the driver is that you installed in step 1. See the compatibility table 1 here:

https://docs.nvidia.com/cuda/cuda-toolkit-release-notes/index.html

  1. Otherwise, follow the instructions in the windows install guide for your CUDA version. Here is the guide for CUDA 10:

https://docs.nvidia.com/cuda/cuda-installation-guide-microsoft-windows/index.html

I had the latest driver installed.
GeForce MX130 is not listed on CUDA enabled GPUs page, but its specifications says it has CUDA support.

(1) CUDA enabled GPUs: https://developer.nvidia.com/cuda-gpus
(2) MX130 specs: https://www.geforce.com/hardware/notebook-gpus/nvidia-geforce-mx130/specifications

Since then, I tried to install an older version, CUDA 9. And all packages installed successfully. However, the error code 52 didn’t disappear from device driver, and PyTorch reported CUDA isn’t available.

Hi,

I got a laptop with an MX150, Windows 10 Home. Thought it would be nice to use the GPU for computation very occasionally for very small experiments. Installed the latest download of CUDA 10.

When I let CUDA 10 install its driver, Windows’ Device Manager shows the device as having errors, and the same error code 52 from above. When I use the latest one available to download from Nvidia, Windows is happy with the driver (Device Manager has no errors for it, and shows its memory resources), but it seems the GPU can’t be flipped into TCC mode using the command:

nividia-smi -dm

It says:

“Unable to set driver model for GPU 00000000:02:00.0: Not Supported”

As I understand, TCC mode must be enabled to use CUDA for computation.
So, does this model really not support use for computation?

Will it be the same if I switched the laptop to Linux?

A bit perplexing, pytorch seems to detect the GPU despite the above now.

Thanks!

The driver issue is expected and part of the windows driver signing system. There should be no problem using the latest driver that windows is “happy” with.

TCC is not required for CUDA usage. It’s beneficial, not required.

Laptop GPUs in general, and GeForce GPUs in general, cannot be placed into TCC mode.

As you’ve discovered already with Pytorch, your GPU is usable for CUDA computation, subject to various limitations, such as a kernel runtime duration limit.

I had the same problem, to be honest this question was the last question that I’ve read to solve my problems. I’ve made a blog on medium to help another users https://medium.com/@nicerova/cuda-on-windows-the-definitive-guide-b4130b9fc419

You only need to reinstall CUDA Tool kit please check in the link above.

My apologies for putting this link back, but in my opinion, it is a good way to introduce more people in the world of CUDA