CUDA 10.0 installation kills Windows 10

I am trying to install CUDA 10.0 on a fresh HP Omen laptop (with GeForce GTX 1070) running Windows 10. Installation works well, then it asks for reboot but once I reboot it would never load Windows, goes to recovery and says recovery is unsuccessful. I wasn’t able to fix it in any way but wiping it away and restoring OEM setup. Repeated second time, same result.
Please advice. Thank you.

The only component I could imagine that would be involved in this scenario is the GPU driver. I have no idea if the GPU driver (install) is actually causing this, or why it might be causing it, if it is.

However, If you have windows 10 installed (and running correctly) on that laptop, presumably a driver is already installed for the GPU. If that is the case, based on the GPU driver version that is installed, and referring to the driver/CUDA version compatbility table:

https://docs.nvidia.com/cuda/cuda-toolkit-release-notes/index.html#major-components
(scroll down to table 1)

you could choose a CUDA version that is compatible with your installed/working GPU driver, and install that version of CUDA. When you do so, you can skip the driver install portion of the CUDA install process completely, by selecting advanced install options, and deselecting the driver install checkbox.

You can also attempt to install a driver separately, by using the driver wizard at http://www.nvidia.com/drivers to select the most recent driver for your laptop. If it is a 411.xx or later driver it should work with CUDA 10. If that driver install can be completed successfully, then you should be able to install CUDA 10 using the CUDA 10 windows 10 installer package, and deselect the option to install the bundled driver.

You are right, it was because of the driver. I installed one from laptop vendor (HP website) instead and it worked well. The latest driver there was 416.16 so I was also able to install CUDA 10 on top of it, I just disabled bundled driver installation when installed CUDA.

Glad you got it sorted out. Using a driver provided by the notebook OEM is definitely the best solution, I should have mentioned that.

Had the same problem on another laptop. It’s due to a driver signing issue. Microsoft has changed the signing process and not all NVIDIA drivers apparently comply.
You can solve disabling e Secure Boot from UEFI bios. I have to remind you that it makes your pc less secure. You can google about SecureBoot to decide whether you absolutely need it, or you can do with it disabled.

I am having the same issue with the installation. After installing cuda_10.1.105_418.96_win10.exe, I couldn’t get in. I’m not familiar with installing drivers so this has been a painful series of lessons. I have tried reading the docs mentioned here but nothing seems to synch up with what I see on my laptop. I could really use some help so that I don’t have to reinstall everything again.

Tried the chat and it was pretty worthless. It felt like he was talking to six different people at once and never answered any of my questions with anything approaching a technical answer. Based on
Robert_Crovella’s link, it looks like I can only install CUDA 9.0 because my NVIDIA driver is 391.25. Unfortunately, I don’t know if it will work or not. I’m not looking forward to re-installing my OS for a second time or having to turn off Secure Boot in the BIOS because the driver isn’t signed correctly.