WIndows 10 CUDA installation failure solved

If the installation of CUDA is failing on Windows 10 its most likely failing because you have GeForce Experience installed.

To fix this do a custom install without GeForce Experience and drivers, I have 3 Windows 10 machines with various OS releases on them (general and developer releases) and it works on each one of them.

I hope this helps.

4 Likes

thanks, it worked when disabling Visual Studio Integration also

2 Likes

Thanks both of you. I’ve been trying it for hours, now it worked.

I just wanted to say thanks to both. Disabling Visual Studio Integration fixed the problem for me as well.

For those who see this after me, Visual Studio Integration is under the CUDA installation options tree menu. I also did not install:

  1. GeForce Experience Software
  2. GeForce Drivers
  3. PhysX

I had newer or equivalent versions of these at the time of installation, so I did not include them in the installation. I felt that I should include this information just in case it does actually matter and help someone.

2 Likes

Yes, it solved an issue.
Thank you.

I have disabled-
GeForce Experience Software (had already installed newer version)
GeForce Drivers (had already installed newer version)
PhysX (had already installed newer version)
Visual Studio Integration.

1 Like

I tried to install cuda…but I am getting same problem with or without GeForce disabled…is there anything I need to do…?

Thank you so much! I solved the problem by disabling visual studio integration!!!

I just wanted to say thanks again. Disabling Visual Studio Integration fixed the problem for me as well.

i have the same issue when trying to install CUDA 9.0. How to disable visual studio integration?

How to installer Visual Studio Integration on this version ? / I want build my project but i cannot install it. ( sorry for my english not good)

As far as I can tell, the installer installed everything I asked it to and it seems to work, despite the installer claiming everything failed to install.

Can I please know where is “visual studio integration” located? and how to disable it?

Update : I am unable to uncheck it , if I uncheck visual studio integration ,even the cuda gets unchecked

Any one who is facing this problem, I was also facing the same problem. I had done everything above but still it did not help me. Then I did the following:

  1. searched for storage settings (in next to windows icon)
  2. clicked on apps and features option
  3. scrolled down and uninstalled every options that had nvidia written. (Restart is required after uninstalling)
  4. Again installed the cuda with recommended option instead of custom. (success) :)