NVIDIA CUDA [Version 9.0] Installer Failed

Hi, I just got a GTX1060 card, which I used to swap out my AMD R9. I also used DDU to uninstall my AMD display drivers. I am running Windows 7 64-bit. I have Visual Studio 2017. I am on the latest version of the display drivers [385.69]

Going through the CUDA Toolkit Download page, I get the Windows 7 x86_64 local executable. The wizard just says that the installer failed. Does anybody know what could be causing this? Is there somewhere where I can download an earlier version (CUDA 8)?

FIXED:
uncheck visual studio integration after doing a custom install

Same problem here, why not anybody reply to those question even ?

Have you followed the instructions in this document:

http://docs.nvidia.com/cuda/cuda-installation-guide-microsoft-windows/index.html

Also, there are warnings that installation can fail if Windows Update is running during installation.

Did you install VS 2017 with the C/C++ development tools?

I have Visual Studio 2017, I’m pretty sure the C/C++ dev tools are included in the install? Not entirely sure.
Windows Update was not running over the multiple times I attempted an installation. The installation procedure itself looks pretty straightforward, download the kit and install via the wizard. The one thing I did not do that is on that page is comparing the checksums, but I also downloaded both versions of the installer each several times.

Either way, I found the legacy releases page and I’m currently content with CUDA8

I have the same problem, installation interrupts in between.

CUDA 9.0 version
VS 2017 with 2015 c++
GPU 1050 Ti

Please help me out to install CUDA toolkit & cuDNN so that I can start working on Deep Learning libraries using GPU


should I go with

CUDA 8.0 version
visual studio 2015 ?

Same problem here. Seems to be related to the n insights visual studio integration. If I try to install just that I get an Direct X error related to a Version from June 2010.

Im on windows 10 latest version with latest creators update
I’ve installed Visual Studio 2017 Community Edition and 2015.3 CE.
Tried Cuda 9 and Cuda 8. Same issue.
Once half a year ago I had it installed with no problems, but now that…

can somebody help?

For CUDA 9, there appear to be some VS2017 installs that the installer refuses to work with:

https://devtalk.nvidia.com/default/topic/1024655/cuda-setup-and-installation/cuda-9-0-176-installer-fails-every-time/

One possible workaround is to remove VS2017, install VS2015, then install CUDA 9. I acknowledge this may not be acceptable for all users. With respect to CUDA 8, VS2017 is not supported in any form with CUDA 8.

But the Nsight integration installation seems to work. If I install just the standalone it does the installation for the VS2017 integration but aborts in the directly following step installing DirextX Redistributables doesn’t work. Afterwards he unrolls all changes. Is it possible to somehow supress the directx install. Since its windows 10 it shouldnt be necessary

I am having the same issue. Any resolution yet?

Excited to try tensorflow on my titan…

I solved it by just not installing the nsight integration with the installer. If you are using another IDE it is not necessary anyways. Also I downgraded to cuda 8 with cudnn 6.1, python 3.6. I dont use anaconda anymore. I think a plain python3 64 bit installation with pip3 install keras, tensorflow-gpu … is fine. Hope it helps.

Yeah I just reverted back to Tensorflow utilizing cudnn6.

No big deal. As long as it works I guess, was just excited to try and build from sources with the latest distribution

Solved by unchecking “visual studio integration”

which for me is totally fine as I do most of my work in python.

hello sir, i have installation problem with cuda 9.1, can any one help me with that

hello sir, anyone is there …??

The following worked for me on Windows 10, Visual Studio 2017 including VS integration:

  1. Download the Offline Installer (not the network)
  2. Extract the installer (the .exe file) using 7zip to a folder
  3. Run setup.exe that is inside that folder. Follow all prompts.
1 Like

Can confirm.
Tried the network installer (win10 x64 / vs 2017 community) - FAILED

Tried the method above - WORKED

Thank you very much

This did not end up working for me, even with the local installer

Make sure your visual studio has the VC++ 2015.3 Tool Set (v140) installed. You can check it by going to Tools -> Get Tools and Components. Switch to the Individual Components tab and look for it. If you dont have it installed, you’ll have to unistall CUDA, install the package, and reinstall cude (following the local installer method)

Hello
How can i uncheck visual studio integration ???