GTX 1080 with CUDA 7.5 not working ?

I’ve a GTX 1080 with the latest driver.
I’m running Windows 10.
I’m using VisualStudio 2012.
Now I’ve installed CUDA 9.1.
I could not install CUDA 7.5. At least not with what I can download from nVidia.

My C++ project is using CUDA 7.5

Now I can’t load it anymore into VS and get it started because the CUDA 7.5 environment isn’t installed.

How can I install CUDA 7.5 with a GTX 1080?
Any help would be appreciated.


Leave the driver as-is. Install the CUDA 7.5 runfile installer and skip the driver installation step (i.e. answer no to install the driver). Point your PATH and LD_LIBRARY_PATH at the cuda-7.5 directories. Then you should be able to run your CUDA 7.5 app. It’s possible that some things still won’t work correctly, trying to use CUDA 7.5 on a cc6.1 GPU. It’s probably better if you rebuild the app against CUDA 8 or CUDA 9.

If you can’t install CUDA 7.5, and your description is “I could not install CUDA 7.5” and you expect help with that level of information, I won’t be able to help you. You’ll need to explain much more fully what you did and what happened when you tried to install CUDA 7.5

And if the CUDA 7.5 app you are trying to run isn’t compiled with PTX, then all of this won’t help. It still won’t run on a cc6.1 device.

I’m starting the installation Software of CUDA 7.5, which then as a first step checks if the system is ok for installation.

And there it says “This nVidia graphics driver is not compatible with this Windows version.”

The Windows version is 10. The graphic driver is 390.65. The hardware is GTX 1080.

Where can I see, if it’s a cc6.1 device?

And where can I see, if it’s compiled with PTX?

GTX 1080 is a cc6.1 device. If you want to check it yourself, run the deviceQuery sample code.

The driver in the CUDA 7.5 installer won’t be useful anyway. You want to skip driver installation. And there have been some newer versions of windows 10 released by Microsoft since CUDA 7.5 was released. So it’s possible there is an issue there. But as a first step I would try to just skip the installation of the driver. There should be a advanced option checkbox to do that.

You can use

cuobjdump -ptx my_app.exe

to see if it is compiled with PTX

Hi txbob,
based on your remarks I re-downloaded the latest version of CUDA 7.5, which is CUDA7.5.18_win10.exe
and when I started that installation I at least passed the system check.
I got a warning that there might be problems but I could continue.

In the “Options” phase I de-selected the driver installation as you suggested.

The installation was successful.

Now my software is working with CUDA 7.5 and GTX 1080 under Win10.

Thanks txbob. Good job nvidia.
Best regards,

Hi all,

I was also in the same situation as naske, however using slightly different PC specs:

  • OS: win7
  • Graphics card: gtx 1070
  • CUDA version 9.1

Following txbob’s suggestions solved the issue.

The C++ software was embedded into LabVIEW.

Thanks again guys!