HELP! How to install CUDA SDK 2.1 under Ubuntu 8.10?

does not support??

I installed all of what you are mentioning a few days ago with hardly any problems. If you actually ask something I may be able to help you.


That is correct.

i have non cuda card and ubuntu 8.10
i found such advice:

View Full Version : [all variants] [howto] … run nvidia CUDA on Ubuntu 8.10 Intrepid
February 5th, 2009, 06:06 AM
This is for anybody interested in running nvidia CUDA on Ubuntu 8.10.

First, you have to assure that your nvidia card supports CUDA.
Check the list here:

Now since Ubuntu 8.10 comes with nvidia driver 177 we will make it all working for this particular driver. If you use another one you have to also download other versions of CUDA toolkit and CUDA SDK.

  1. You must enable NVIDIA proprietary driver version 177 in
    System->Hardware Drivers. If you do this correctly, you will be able to open NVIDA X Server Settings. It is quite probable that you have already done this step before.

  2. Go to
    choose your platform (Linux-32) and Ubuntu 7.10.

Download CUDA 2.0 toolkit: CUDA Toolkit for Ubuntu 7.10
and CUDA SDK 2.0. Save them to say, ~/Desktop.

  1. Open terminal and

cd ~/Desktop
chmod u+x
chmod u+x

  1. Now we shall install the toolkit. You have to be root. The best option is just to confirm /usr/local/cuda as the destination directory.

sudo ./

Then, we install the SDK with examples. You may do this in your home dir, so you don’t have to be root any more:


  1. You ahve been prompted to change $PATH and $LD_LIBRARY_PATH so we have to edit ~/.bashrc. Run

gedit ~/.bashrc

and paste the following code somewhere inside:

extension for nvidia CUDA

export PATH

  1. Now, we are almost done. The next thing you must do is to add gcc 4.1 and g++ 4.1 since CUDA uses them and Ubuntu 8.10 by default use gcc 4.3:

sudo apt-get install gcc-4.1 g+±4.1

Now we must set alternatives properly so, gcc 4.1 will be used by default. You may always switch back to 4.3.

sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.1 60 --slave /usr/bin/g++ g++ /usr/bin/g+±4.1
sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.3 40 --slave /usr/bin/g++ g++ /usr/bin/g+±4.3

  1. Finally you have to install all the stuff for OpenGL development:

sudo apt-get install mesa-common-dev freeglut3-dev glutg3-dev libglut3

you will be prompted for other packages. Confirm them all.

Now we are ready to compile the examples. Go to the directory where you installed the SDK and


If you haven’t seen any errors (although you may see warnings) you are successful.
Let’s try to run a demo:



After this when i ran make emu=1 from nvidia sdk directory
i had such mistake
make[1]: `/home/mrbloom/NVIDIA_CUDA_SDK/projects/imageDenoising’
/usr/bin/ld: cannot find -lXmu

i installed all packets that connected with libXmu

After this i compiled sdk projects
but if i run for example deviceQuary i have such error:
cudaSafeCall() Runtime API error in file , line 59 : feature is not yet implemented.

but i can run example that use only cuda.h