ubuntu 11.10 nvidia drivers problem

Hello! I tried to install the Nvidia drivers on my 11.10 ubuntu.
I done everything what told on http://www.dickscheid.net/2011/10/19-cuda-ubuntu-1110/ and http://blog.ryant.org/2011/12/installing-cuda-toolkit-on-ubuntu-1110.html
then i reboot, now i see only title “Ubuntu” and ~5 points, I cant even switch to console (ctrl alt f 1-6)
anybody know what i can to do to save my ubuntu?

You might want to try Ubuntu 10.10 instead. This version is listed as being supported.

I had the same problem last week. During startup (when you see the ~5 points), if you press ALT-F2 the splash screen should disappear and you should be able to login on the command line. If you do that and go to /usr/local/bin, is there anything there? My problem was that for some reason that whole directory was erased, including things like Python. So in the end I just gave up and did a fresh Ubuntu 11.10 install. Miraculously, the second time I tried to install the CUDA toolbox, everything went fine. So maybe check whether there is anything left in your /usr/local/bin and if not, brace yourself :)

You can try to backup and delete /etc/X11/xorg.conf. Worked for me a couple of times when the driver wasn’t working with the kernel.

Thanks a lot! I install Ubuntu 11.04, no problems, so easy, CUDA works=)

Below are the rough notes of steps I took for getting NVIDIA drivers to work on my Ubuntu 11.10 system. My system has two NVIDIA cards (GeForce 8400 GS for the two monitiors, and GeForce GTX 460 for CUDA development) I suggest reading through all the steps first to see what didnt’ work and then what did work.:

Notes For Installing CUDA on Ubuntu 11.10 Oneiric

Installing Video Drivers:

First, when installing Ubuntu, don’t select the driver that the install gives a number for (errantly defaults/highlights version at top of list it presents), rather select current and current updates.

Later when installing video drivers to be setup for CUDA the dickscheid.net blog shows:

sudo apt-get install \

nvidia-current\

nvidia-current-dev\

nvidia-current-updates\

nvidia-current-updates-dev

This will get the 280.13 driver, which works for Ubuntu, but the CUDA sample application deviceQuery will fail. The 290.10 driver is what is needed. I first tried downloading it from:

http://www.nvidia.com/Download/index.aspx?lang=en-us

However, when installing this version from the manually downloaded file (typing sudo ./NVIDIA-Linux-x86_64-290.10.run ), there were some concerning msgs about the kernel version(e.g “NVIDIA kernel module has a version of 280.13 but this NVIDIA driver component has a version of 290.10”), and also a msg “the distribution provided pre-install script failed”. Also, it asked “Install Nvidia’s 32-bit compatibility OpenGL libraries” which I answered yes to.

Then I came across something about adding a repository to install the 290.10 version:

http://www.noobslab.com/2011/09/nvidia-drivers-for-ubuntu-1110-oneiric.html

To install/Update Nvidia card drivers open Terminal (Press Alt+F2 and type: gnome-terminal) and copy the following commands in the terminal:

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates

sudo apt-get update

sudo apt-get install nvidia-current

which is also referenced here:

http://www.ubuntuupdates.org/ppa/ubuntu-x-swat?dist=maverick

Installing nvidia-current after adding the repository causes 290.10 to be installed without the concerning msgs. Note: before adding the repository sudo apt-get install nvidia current installed 280.13. However, if one then does sudo apt-get install nvidia-current-updates 280.13 will again replace 290.10.

Note also that to install I had to stop the X server with:

CTRL+F2 to get terminal

sudo service lightdm stop

sudo apt-get install nvidia-current (yields 290.10 driver after adding repository)

sudo service lightdm start

CTRL+F7 to get back to GUI (got black screen couldn’t get into GUI)

So then I try:

sudo apt-get install nvidia-current -updates (yields 280.13 driver)

sudo reboot or CTRL+ALT+F7 gets me back to GUI but with 280.13 driver.

Also, each unsuccessful cycle of trying drivers I’d have to uninstall the drivers with:

sudo apt-get remove --purge nvidia-current

Finally I came across an article:

http://www.moonlitdog.com/nvidia_ubuntu

(How-to Install Nvidia Drivers on Ubuntu 11.10)

this said:

[b]1) add “nomodeset” to the grub bootloader (i.e at the end of the first linux entry)

sudo nano /boot/grub/grub.cfg

e.g. linux /boot/vmlinuz-3.0.0-14-generic root=UUID=… ro quiet splash vt.handoff=7 nomodeset[/b]

Doing this yielded good results with 290.13!!! Could boot into GUI and run CUDA deviceQuery sample successfully!!!

[b]

Here are my notes on installing CUDA SDK and getting deviceQuery sample to build assuming 290.13 driver has been installed:[/b]

Installing CUDA:

Downloaded from Nvidia:

http://developer.nvidia.com/cuda-toolkit-41#Linux

cudatoolkit_4.1.21_linux_64_ubuntu11.04.run

gpucomputingsdk_4.1.21_linux.run

devdriver_4.1_linux_64_285.05.23.run Don’t use as doesn’t work with Ubuntu 11.10

See blog:

http://blog.ryant.org/2011/12/installing-cuda-toolkit-on-ubuntu-1110.html

http://www.dickscheid.net/2011/10/19-cuda-ubuntu-1110/

CUDA_SDK_Release_Notes.txt

(Sort of followed both articles at above links, and the release notes, but per dickscheid.net definitely don’t install the nvidia drivers he recommends as the correct driver is 290.10 and not 280.13, and definitely not the driver that is struck through above. See Installing Nvidia drivers section above)

Right click, select Properties, Permissions and check “Allow executing file as a program”.

Install the open in terminal feature (so you can open a terminal from the nautilus file browser):

sudo apt-get install nautilus-open-terminal

Ubuntu comes with gcc 4.6 and CUDA needs gcc 4.4 so:

sudo apt-get install build-essential gcc-4.4

The following I addded in the .bashrc file in /home/:

export PATH=$PATH:/usr/local/cuda/bin:/usr/local/cuda/lib64

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/cuda/bin:/usr/local/cuda/lib64

And now you need to add the CUDA libs to your library search path, I already had the nvidia_settings.conf file here, though you can add any file with a .conf extension. The lines added are in bold.

$ cat /etc/ld.so.conf.d/nvidia_settings.conf

/usr/lib/nvidia-settings

/usr/local/cuda/lib64

/usr/local/cuda/lib

Now run ldconfig to pick up the changes.

$ sudo ldconfig

Link the 4.4 compilers

If you have multiple gcc versions installed, we need to make sure that nvcc (the CUDA compiler) picks up the 4.4 version. This can be done through flags for nvcc, however we need a link for it called gcc and g++.

Create a new directory in your home, called gcc-4.4 and create a link in here to the 4.4 version of gcc and g++.

$ cd

$ mkdir gcc-4.4

$ cd gcc-4.4

$ ln -s /usr/bin/g+±4.4 g++

$ ln -s /usr/bin/gcc-4.4 gcc

Set the compiler flag in the provided samples

In order to build the supplied samples we now need to modify the supplied MakeFile.

$ cd ~/NVIDIA_GPU_Computing_SDK/C/common

$ vim common.mk

Find a line that looks like:

NVCCFLAGS :=

And change it to look like:

NVCCFLAGS := -ccbin ~/gcc-4.4/

This flag tells nvcc where to find the gcc and g++ compilers.

Make the sample - deviceQuery

We will build the deviceQuery sample, this sample prints output of our CUDA device.

$ cd ~/NVIDIA_GPU_Computing_SDK/C/src/deviceQuery

$ make

$ cd ~/NVIDIA_GPU_Computing_SDK/C/bin/linux/release

$ ./deviceQuery

You should now see the output of the deviceQuery sample.

From Stack Overflow I also did this (which probably wasn’t needed):

As already pointed out, nvcc depends on gcc 4.4. It is possible to configure nvcc to use the correct version of gcc without passing any compiler parameters by adding softlinks to the bin directory created with the nvcc install.

The default cuda binary directory (the installation default) is /usr/local/cuda/bin, adding a softlink to the correct version of gcc from this directory is sufficient:

sudo ln -s /usr/bin/gcc-4.4 /usr/local/cuda/bin/gcc

Miscellaneous:

Per the instructions by Dickscheid.net (see link above) I installed alternatives. Setting those via the command line seemed somewhat a chore so I installed galternatives:

sudo apt-get install galternatives.

Launching this application lets one switch between gcc 4.4 and gcc 4.6 versions.

The following is a redundant line of commands to add the alternate driver repository:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates && sudo apt-get update; sudo apt-get install nvidia-current

I tried the steps on http://www.moonlitdog.com/nvidia_ubuntu to install nvidia geforce gs 8400 on my ubuntu 11.10. but picking up the driver. Can summarize the steps again that worked for you.