Linux CUDA kbuntu/ubuntu 11.10

Hi all.

After a fresh install of Kbuntu 11.10 I installed the kernel-sources and headers, disabled nouveau via GRUB. Ran the Nvidia-development driver and I get this following error.

ERROR: If you are using a Linux 2.4 kernel, please make sure

       you either have configured kernel sources matching your

       kernel or the correct set of kernel headers installed

       on your system.

If you are using a Linux 2.6 kernel, please make sure

       you have configured kernel sources matching your kernel

       installed on your system. If you specified a separate

       output directory using either the "KBUILD_OUTPUT" or

       the "O" KBUILD parameter, make sure to specify this

       directory with the SYSOUT environment variable or with

       the equivalent nvidia-installer command line option. etc.. etc..

Now, I’ve heard someone on this forum saying you don’t need the cuda-developer driver, but I’m studying CUDA programming at University, and I don’t know if you need the dev-driver to compile and run CUDA programs. Previously, I ran CUDA with Ubuntu 10.04 and it was fine.

Kbuntu + Ubuntu comes with the Linux 3.0 kernel. I don’t know if this is the issue.

Has anyone managed to get CUDA working with this distro, or with Linux 3.0?

Thanks.

Hi,

I have the same problem. So far did not come across a solution.

Martin

Hi, I upgraded yesterday to Ubuntu 11.10 (@64 bit). Then I downloaded CUDA toolkit and SDK. It looks like it’s working with default driver installed by Ubuntu (280.13)

and there is no need to install the nvidia dev-driver separately. The only problems that must be solved manually to compile CUDA SDK are:

–compiler version: I installed gcc-4.4 and g+±4.4 and used those to compile the SDK (eiter via alternatives or special script)

–for some reasons, some demos were complaining about -lcuda library (not found). In fact, libcuda shared library is installed by the nvidia-current driver (default by ubuntu) in /usr/lib/nvidia-current ). I was playing with ldconfig but apparently, it does not create libcuda.so symlink which is needed to compile the demos (libcuda.so.1 is not sufficient…). Although it’s not a real solution, I made it working by editing common.tk file (in CUDA SDK_DIR/C/common ), I added "-L/usr/lib/nvidia-current " on the line 278 (so now it’s LIB+= -L/usr/lib/nvidia-current -lcuda ).

Afterwards, I compiled all the demos and they are running. Surprisingly, manual playing with ldconfig solved somehow a problem with OpenGL in Matlab that started working as well.

Anyway, I think references to shared objects in Cuda SDK should be improved somehow…

Igor

Interesting.

Are you able to compile and run CUDA programs then? Would I need to also blacklist (via grub) the nouveau module before I attempt to install the driver? Or would this all be automated the I install the Nvidia proprietary driver.

Yes, I could compile any CUDA programs (all the examples from Nvidia as well as another CUDA-enabled framework I am using for medical simulations). Everything is working fine.

I cannot answer your question concerning blacklisting, as in my installation, the proprietary NVIDIA driver (280.13) was installed directly by the distribution (as the 3rd party driver), so I did not have

to bother with nouveau… However, this may depend on your card (e.g. there are quite huge problems if your card is Optimus-enabled, but this is only case for laptops).

My card is GT430). Also, I checked “install 3rd party software/drivers” (or something similar) during the installation of ubuntu, so maybe that’s why the system used proprietary driver instead of nouveau.

As I said in the first posting, I did not have to install/resolve anything apart from minor compilation issues (gcc-4.4 and library path for libcuda.so)

–Igor

Hi, my laptop is Asus K53SV (has an Optimus-enabled card)
and I am using Ubuntu 10.10
I could not install the nvidia-dev driver
if I upgrade to 11.10 could it be a solution?

Thx mate,

this helped me a lot!

I had this problem either, the whole day!

Regards

ibi

I have CUDA working in exactly this manner on Ubuntu 11.10. The problem with this method is cuda-gdb won’t break inside of gpu code. I am doing development and that is a must have feature. cuda-gdb runs just fine but doesn’t break until it gets back to the host code. I had this problem in 11.04 but installing the dev drivers solved the issue. However in 11.10 the dev drivers won’t install because the kernel is too new or something. Anyone have better luck? NVIDIA it sure would be nice if you could release an update to the dev drivers so I can get them installed on 11.10.

I am running Ubuntu 11.10 and successfully installed the latest (285.05.15) driver (which comes with the 4.1 RC cuda toolkit). It all installed fine, as long as I rebooted after installing it. I never had issues with cuda 4.0 on 11.10 with the standard drivers, but then again I never used cuda-gdb.

What is the exact error you are getting?

I followed the advice here and on http://www.dickscheid.net/2011/10/19-cuda-ubuntu-1110/ .

I can compile the programs, but when running them, I get a notice that no CUDA capable device is detected.

I have an onboard graphics card (ATI) and NVIDIA tesla. The nvidia driver with Ubuntu 11.10 loads, but it shows as it is
used by 0 devices and it is marked as [permanent].

What could I be doing wrong?

Gorazd

Hi

yeah I also used that guide except the last part where you change the LINKFLAGS line becourse that ****ed it up so I could not compile it. But without it compiled fine.

But I don’t get the a CUDA device either…

Any help would be appreciated!

had similar trouble to install current nividia drivers on ubuntu 11.10
i.e

run the driver installer

sudo ~/Downloads/devdriver_4.0_linux_64_270.41.19.run

used this forum: http://forums.fedoraforum.org/showthread.php?t=268382
i.e
patch code
cd /path/to/run_file #change the path to suit
wget http://leigh123linux.fedorapeople.org/pub/patches/nvidia_kernel-3.0-rc1.patch
chmod +x devdriver_4.0_linux_64_270.41.19.run
./devdriver_4.0_linux_64_270.41.19.run --apply-patch nvidia_kernel-3.0-rc1.patch

than did:
ctrl+alt f1
sudo stop lightdm
sudo sh ~/Downloads/NVIDIA-Linux-x86_64-270.41.19-custom.run
…sucessfully installed the driver
sudo reboot

hope it helps… :smile:

Hi,

Followed the suggestion. Managed to compile the driver, and it loads, but it still reports that no CUDA device
was found.

Some things:

  1. lsmod reports that nvidia module is permanent and 0 devices use it.
  2. I have an on-board ATI card (just for display) and a Tesla card.
  3. This is the information in /proc/driver/nvidia/gpus/0/information

Model: Tesla C1060
IRQ: 18
Video BIOS: ??.??.??.??.??
Card Type: PCI-E
DMA Size: 32 bits
DMA Mask: 0xffffffff
Bus Location: 0000:02.00.0

Is that be a problem? If yes, what can I do?

I would greatly appreciate any help.

Gorazd

Found a solution. To elaborate:

  1. the drivers provided with ubuntu suffice, and the devdriver file is not needed.
  2. i think the reason i got ??? in the VIdeo bios is becuase this card is not used for video output.

Now the main problem:
The reason was that the nvidia device in /dev was not created for some reason. After running nvidia-xconfig the device is created.
As a temporary solution I run nvidia-xconfig and remove the Xorg file it creates.

Hope that helps someone.