Cuda Error in NCHWToNCHHW2: 33

i run the demo of yolov3 implemented by TensorRT, the demo’s repository is https://github.com/jkjung-avt/tensorrt_demos#demo-4-yolov3, but when i add the follow code :

a = tf.constant([1.0, 2.0], name="a")
b = tf.constant([3.0, 4.0], name="b")
result = a + b;
with tf.Session() as sess:
    print(sess.run(result))

the demo cant run normally, and print error “Cuda Error in NCHWToNCHHW2: 33”, what’s the problem ? please give me some advise, thank you :)

tensorflow and tensorrt cant be used together ?

Hi,

TensorFlow and TensorRT can be used together.

A possible cause is same parameter might leads to format error.
Would you mind to check is there any redefined parameter in your program?

Thanks.

i have checked param, there is no same param, could you tell me whether there is other reason ? the code can be found in github : https://github.com/jkjung-avt/tensorrt_demos/issues/67, thank you :)

@AastaLLL, what about attentions to use tensorflow and tensorrt together ? any document ?

Hi,

We will check your program and share more information with you later.
Usually, we don’t launch TensorFlow “inference” and TensorRT engine together but only using TensorFlow for model architecture.

Although TensorFlow also has its inference implementation, we convert the model into TensorRT instead.
Some information can be found here: https://docs.nvidia.com/deeplearning/sdk/tensorrt-developer-guide/index.html#build_model

Thanks.

thank you, expect for your good news

my project needs two inference, one inference needs another inference’s result. can use two tensorrt engine in one project ?

can use two models on one xavier developer kit at same time ?

This issue is fixed by jkjung-avt’s comment in his GitHub:

Thanks.

Have you solved it? I introduced a trace model (pbfile) and TRT, and reported the same error as you

This problem has not been effectively solved. How to deal with it?
Check out my other topic
"Cuda Error in NCHWTONCHHW2: 33 (invalid resource handle) ", How to solve it? - Jetson & Embedded Systems/Jetson Nano - NVIDIA Developer associations

Hi, gzchenjiajun

Please check the following update in your topic:

Thanks.