CUDA hangs on memcpy

Hey all,

I’ve recently started testing/developing/profiling my kernels in Windows XP (as opposed to Vista which I was using primarily), and I’ve come across an odd error…

Under windows XP, on occasion memory copies will freeze (eg: they block the thread forever, as if it’s waiting on something internally)…
I’ve had it happen to all kinds of memory copies (cuMemcpyDtoD, cuMemcpyHtoD, cuMemcpyHtoD, cuMemcpy2D (again, all directions H<->D<->D), in various different places in my applications (randomly) - there doesn’t seem to eb any pattern, just after a few seconds/minutes - it’ll hang on a memory copy until I terminate the process.

This has never happened on Windows Vista.

Has anyone else experienced this issue, or maybe know what it could be related to?

CUDA 2.0
Windoze XP, 32bit, SP3
Driver Version: 180.48

P.S. Sorry if this has been answered before, I tried searching the forums but I keep getting an error about flood protection (despite not having tried a search in the last 2-3 minutes).

This appears to be a driver specific issue, updating the driver fixed the random freezing.

Can you tell us Which driver solved your problem? 180.6 ??

@ tmurray,

Almost every1 looks to be having this flood-control problem not allowing us to search the forum. I had the same experience as smokey sometime back. Can this be fixed, please?

Thank you

Best Regards,


I upgraded to 181.20.

I don’t actually know who maintains the backend of the forums, sorry.