CUDA nvcc x64 BUG Hope anyone answers soon

Hey guys,
For 2 days now am only trying to compile using the nvcc 64-bit on my Windows 7 machine. Always getting this … Only MSCV 8.0 and 9.0 are supported.
I’ve tried all possible combinations, I even downloaded older versions of MSCV … nothing works

Am using the Windows SDK 7 … and downloaded the Windows SDK 6 … no use !!

here is what i’ve tried so far

nvcc -ccbin “C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin” …
nvcc -ccbin “C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin\amd64” …
nvcc -ccbin “C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin\ai64” …
nvcc -ccbin “C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin\x86_amd64”
nvcc -ccbin “C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin\x86_ia64”
nvcc -m 32 -ccbin “C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin”
nvcc -m 32 -ccbin “C:\Program Files\Microsoft SDKs\Windows\v6.0\VC\Bin”
nvcc -ccbin “C:\Program Files\Microsoft SDKs\Windows\v6.0\VC\Bin”
… nothing works at all !!!

“nvcc fatal : nvcc cannot find a supported cl version. Only MSCV 8.0 and 9.0 are supported”

I’ve also tried using the 32 bit nvcc on my 64 bit machine … NO USE TOO !!! and that was really strange … moreover some of the cuda programs wouldn’t run because of that.

MoreInfo

cudatoolkit_2.3_win_64.exe … latest one one site at the time i’m writing this
windows SDK 7
Windows 7 (64-bit)

And running the environmental variables doesn’t solve much … although I’ve found lots of ppl writing that here dunno why(i’ve tried it to after feeling desperate)

The only thing that works … but not though the whole compilation process … is this
nvcc -foreign -m32 -ccbin “C:\Dev-cpp\bin\gcc.exe” … compiles at first then gives me the same error … doing the same “-foreign” with the MSCV results in a runtime error in most cases

I guess I’ll have to start reverse engineering the nvcc to figure our what the hell is wrong with it … which would be time consuming.
If anyone knows anything … please help !!

I am afraid I do not fully understand what you mean by “running environmental variables”?

My suspition would be somewhere there as well. Maybe you could print your environemental variables overe here so we could check them out and confirm or discard the hypothesis that the problem lies there…

I am running nvcc with -ccbin “C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin” on my Windows 7 without any troubles so I don’t think that the problem is inside of nvcc.

In case you didn’t see yet - http://www.rapidee.com/en/about - is a nice env. variable editor.

Sorry … wrote that in a rush … I meant running the bat files to set the environmental variables … which is not necessary cause i already pass all the parameters at compilation.
Is your windows 7 32 bit or 64 ?? and which SDK are you using

Windows 7, 64bit.
CUDA SDK 2.3
Visual Studio 2009 v. 9.0.21022.8 RTM

but I think the problem is not in the software but in the settings!
If you don’t show me the settings I may not be able to help you…

I had the same problem long time ago, and I don’t remember how I solved it.
Oh yeah, I started using VS, I believe :teehee:

I’ll try to use command line in my Win7 machine today, see what happens.

The real question is: do you have Visual Studio 2005 or 2008 installed? It’s complaining that it can’t find the compiler, CL.exe. And I’m not sure if the Windows SDKs contain the 64-bit compiler… I know for sure VS2008 Express does not have it.

I’m not using Visual Studio IDE … I’m compiling from the command line, I just need someone using the Visual Studio to tell me the Log of the compilation (i guess you could find a tab called Log somewhere) , so i could type it “as is” on the command line … or at least pasting here the Make file if existing
Maybe then i could manage to integrate nvcc with Netbeans or Dev-cpp
Thanks